xmlgraphics-fop-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Louis.Mast...@log-net.com
Subject Re: fo:marker initial child error
Date Thu, 01 Jul 2004 14:57:39 GMT

Here is a sample table cell from the xalan processor (I stripped out almost
anything that might cause an issue):

<fo:table-row>
<fo:table-cell>
<fo:marker
marker-class-name="bill_of_lading">RBHZ&amp;P000000111</fo:marker><fo:marker
 marker-class-name="carrier"/><fo:marker
marker-class-name="vesselVoyage">/</fo:marker>
</fo:table-cell>
</fo:table-row>

I get the following errors:

[ERROR]: fo:marker must be an initial child,and 'marker-class-name' must be
unique for same parent
[ERROR]: fo:marker must be an initial child,and 'marker-class-name' must be
unique for same parent

It looks like the first marker is OK, but anything after that generates the
error.

Anything stand out?
-Lou



                                                                                         
                                       
                      "J.Pietschmann"                                                    
                                       
                      <j3322ptm@yahoo.         To:      fop-user@xml.apache.org       
                                          
                      de>                      cc:                                    
                                          
                                               Subject: Re: fo:marker initial child error
                                       
                      06/27/2004 18:01                                                   
                                       
                      Please respond                                                     
                                       
                      to fop-user                                                        
                                       
                                                                                         
                                       
                                                                                         
                                       



Louis.Masters@log-net.com wrote:
> I'm having a problem with my markers in fop 0.20.3.  The marker data
> displays correctly in the PDF, but I get a log full of the following
> message:
>
> 1088163278596 -> ERROR  [fop]:fo:marker must be an initial child,and
> 'marker-class-name' must be unique for same parent

The most common reason for the "must be an initial child" message is
that there is whitespace before the marker. Your code snippet doesn't
give hints for this though. Try to run the XSL transformation
standalone and check the result.

J.Pietschmann


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-user-unsubscribe@xml.apache.org
For additional commands, e-mail: fop-user-help@xml.apache.org







---------------------------------------------------------------------
To unsubscribe, e-mail: fop-user-unsubscribe@xml.apache.org
For additional commands, e-mail: fop-user-help@xml.apache.org


Mime
View raw message