xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Adams <gl...@skynav.com>
Subject update to site/deploy/fop
Date Mon, 27 Feb 2012 08:39:07 GMT
I've been attempting for a few hours now to successfully update the FOP
site directory. After a number of attempts I believe I've finally performed
an update (subject to an upcoming rsync). I noticed that the first time I
was able to perform a deploy.svn successfully, it only updated two files,
two newly added files, and did not update any of the other existing files.

I finally determined that the following lines in
forrest/tools/forrestbot/core/deploy.xml

    <copy todir="${deploy.svn.svn-dir}">
      <fileset dir="${build.site-dir}"/>
    </copy>

were failing to copy the changed (modified) files since the last modified
date on the target directory (work/svn-deploy/forrest-docs) were later than
the just previously built site directory (build/forrest-docs).

This was because the newly checkout out files in the target directory had
the time of checkout as opposed to the last time of commit on the file,
and, consequently, the local site directory files, which are rendered
(built) by forrest prior to the checkout, had older last modified times.

By adding overwrite="true" as follows (along with verbose for a little
debugging help), I finally got all the modified site files copied, and
subsequently committed by deploy.svn.

    <copy todir="${deploy.svn.svn-dir}" verbose="true" overwrite="true">
      <fileset dir="${build.site-dir}"/>
    </copy>

Has anyone else encountered this problem? What is the best way to effect a
shared fix?

G.

Mime
View raw message