xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manuel Mall ...@arcus.com.au>
Subject Re: Fixing leading whitespace on a line (was: How about a release?)
Date Fri, 07 Apr 2006 15:13:50 GMT
On Friday 07 April 2006 19:14, Manuel Mall wrote:
> On Friday 07 April 2006 16:06, Jeremias Maerki wrote:
> > On 06.04.2006 20:50:18 Peter S. Housel wrote:
<snip/>
> >
> > Any insight from the whitespace specialists? I'm not sure about it
> > and don't want to apply that "quick fix" without a second opinion.
>
> I have some time this weekend and will look into this in a bit more
> detail. Shouldn't be too hard to find a "semi-good" fix for this bug.
>
Just a quick progress report.

I have what I think is a working patch. All existing tests pass and a 
new test for white-space="pre" seems to produce the correct results.

Need to do some more testing for some "unusual" property combinations 
like: white-space-treatment="preserve" and text-align="justify" or 
"center" although I am not 100% certain what outcomes to expect in some 
of these cases.

And while I am at it I want to look at the other values for the 
white-space-treatment property (ignore-if-before/after-linefeed).

It also transpired that white-space-treatment="preserve" is sort of the 
same as replacing <SPACE>... with <NBSP><ZWSP>.... This means the Knuth

sequences I generate for the white-space-treatment="preserve" case 
should also be able to be used for zero-width spaces. So I'll look into 
that as well.

> >
> > Jeremias Maerki
>
> Manuel

Manuel

PS: Good to be back working on FOP - really missed it for the last 
couple of months.

Mime
View raw message