xmlgraphics-fop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki <...@jeremias-maerki.ch>
Subject Re: Underlining using FOP
Date Tue, 04 Apr 2006 07:07:48 GMT
(Answering to fop-users@xmlgraphics.apache.org which is the right place
to send questions like this to. Please continue this thread there)

I've tried to reproduce this in FOP 0.20.5 and 0.91beta (you didn't tell
us the version you use), but I don't see the effect you describe in
either version. Are you using a non-standard font? Are there any
inherited properties set on parent elements which are propagated into
this fo:block? It would be good if you could provide a short FO-File
(not a stylesheet) that shows the problem, maybe accompanied with a
screen shot and the note which viewer you use to display the PDF. If you
print the PDF do you get gaps, too?

On 04.04.2006 01:30:51 Leung, Koby wrote:
> Hey folks,
> 
> 	Hopefully I've the correct list. I'm attempting to use FOP to
> generate a PDF with some underlined text, and was having some trouble.
> Here's the snippet of code I'm using:
> 
> <fo:block text-align="center" text-decoration="underline"
> font-weight="bold" space-before='24pt' font-size="14pt">
>   Here is my text, plus I've got some <xsl:value-of select="mySelect">
> blocks too.
> </fo:block>
> 
> The problem is, the underlines are coming through, but are showing
> little gaps between each word and each space.
> 
> So I get __ ___ like underlining, where I'd like a solid line.
> 
> I've tried encasing the static text in an <text> tag, but the behavior
> doesn't change.
> 
> Am I doing something wrong, or have I run up against a limitation in
> FOP?
> 
> Thanks!
> 
> Koby



Jeremias Maerki


Mime
View raw message