xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: batik osgi bundles
Date Sun, 12 Jun 2011 16:01:34 GMT
I poked around some, and now I'm pretty confused.

It seems as if most of what I did was push your 2008 1.7 jars with new
signatures. However, a few of them are indeed new ones which I
presumably built with 1.6.

I'm not sure what to do here, I'm about to go apply for advice.


On Mon, Jun 6, 2011 at 4:31 PM, Martina Kutmon <mkutmon@gmail.com> wrote:
> Hey Helder,
> Thanks for your reply. I will not have the time to play with that in the
> next week, but I will follow up with you!
> It's correct, that you only need the metadata, but we still need to make
> sure that all the dependencies are set correctly.
> I will have a look at the dependencies graph as soon as possible.
> Thanks for your help!
> Martina
>
> 2011/6/6 Helder Magalhães <helder.magalhaes@gmail.com>
>>
>> > Dear Helder,
>>
>> Hi Martina,
>>
>>
>> > Thanks for your reply.
>> > We are using the batik library which is downloadable form the download
>> > page.
>> > So I downloaded the binary distribution for JRE 1.4+ and there we are
>> > using
>> > all the jar files in the lib folder (batik-anim.jar,
>> > batik-awt-util.jar,...).
>> > I want to use these as OSGi bundles in my application.
>>
>> OK, I took a quick look at what's involved and it seems all that it's
>> necessary is appending metadata to the manifest [1].
>>
>>
>> > I could easily make them into bundles myself, [...]
>>
>> Great, that means you already have the knowledge. Could you please
>> file a bug [2] so that we can try to address this in the shipped jars
>> for the next release? If possible attaching a patch and/or which
>> proposed metadata you had in mind. Thanks.
>>
>>
>> > but I am not completely sure
>> > about the dependencies between the separate jar files. So I was
>> > wondering if
>> > you 1) have already a OSGi bundle version of these libraries? or (2) can
>> > help me with figuring out the dependencies between them.
>>
>> 1) No. Recently, bmargulies has helped adding Batik to maven, but
>> apparently it was compiled with JDK 1.6 [3].
>> 2) Maybe. Batik provides a dependency graph [4], although it's a bit
>> outdated.
>>
>>
>> > Thanks,
>> > Martina
>>
>>  Hope this helps,
>>  Helder
>>
>>
>> [1] http://blog.springsource.com/2008/02/18/creating-osgi-bundles/
>> [2]
>> https://issues.apache.org/bugzilla/buglist.cgi?query_format=specific&bug_status=__open__&product=Batik
>> [3] https://issues.apache.org/bugzilla/show_bug.cgi?id=51263
>> [4] http://xmlgraphics.apache.org/batik/install.html#dependencyGraph
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
>> For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org
>>
>
>
>
> --
> -----------------------------------------------
> Martina Kutmon, MSc
> email: mkutmon@gmail.com
> skype: mkutmon
>

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message