xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Helder Magalhães <helder.magalh...@gmail.com>
Subject Re: SVGGraphics2D cannot reproduce gradients (Bug 42387)
Date Sun, 10 Oct 2010 11:11:15 GMT
Hi tiwaris,

> I am facing the exact same problem as described in Bug 42387.
> https://issues.apache.org/bugzilla/show_bug.cgi?id=42387

No, I believe you have faced bug 49558 [1]. I've marked it as
duplicate (although "works for me" might be formally more correct as
there's no formal proof) to reflect that.

> This is what I am doing in my application.
> I am drawing my model which contains SVG icons. Now I want to add the
> functionality to store a snapshot of my model as SVG file. This amounts to
> "Rendering a GraphicsNode object onto SVGGraphics2D". Th gradients are
> painted black in my model.

Yup, this really seems like bug 49558. Please attach a test case to
bug 42387 and reopen it if it's still occurring after following the
suggestions below.

> This bug is marked resolved as of 2007. I am using Batik 1.7, but am still
> seeing this bug.
> Any ideas/helpful suggestions?

You may try to apply the changes made by Thomas (in revision 961322
[2]) to your working copy if you are compiling Batik from source.
Else, you may want to try with a 1.8pre nightly build [3] and check if
it helps (if it does, please confirm it by replying to this thread or
to bug 42387).

Hope this helps,

[1] https://issues.apache.org/bugzilla/show_bug.cgi?id=49558
[2] http://svn.eu.apache.org/viewvc?view=revision&revision=961322
[3] http://xmlgraphics.apache.org/batik/download.cgi#Current+development+snapshot

To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org

View raw message