xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Lundquist <lundquist.m...@gmail.com>
Subject Re: Flow problem
Date Wed, 02 Apr 2008 17:19:37 GMT

(Bump...) anybody? :-)

Mark Lundquist wrote:
> Hi,
> I'm using Batik in just a very small way in some Web applications... our 
> graphic designer comes up with these designs for web pages that call for 
> page headings, etc. to be displayed in various artistic fonts that 
> browser's don't know about... so, I use SVG to render the text and 
> rasterize it to PNG or whatever.
> I have one Web site where this has been working for the last 1-2 years, 
> and then we upgraded the server from one version of OS X to another, and 
> all of a sudden this doesn't work right anymore.  For whatever reason, 
> it works perfectly on my MacBook Pro.  Both are running Java 1.5 with a 
> slight difference at the JRE build number level.
> You can play with it and see... here's an example:
>    http://test.pdxrm.wd-2.net/navmenu-heading.png?text=xxx+yyyyyyyy
> Whatever's in the "text" parameter is supposed to display in the box. As 
> you can see, for some reason, the second "word" is just getting 
> completely lost somewhere.  Now, while fumbling around with this I ended 
> up discovering something that seems pretty strange (at least, to me...) 
> Try this:
>    http://test.pdxrm.wd-2.net/navmenu-heading.png?text=xxx+yyyyyyyy+zzzz
> That's right, with the extra text added at the end, somehow the text 
> that is now "in the middle" (the "yyyyyyyy") and was lost before, now 
> appears!  So, it's not as though flowing isn't working... but something 
> about isn't working right, or at least not working the way I expect. But 
> I'd feel better if I thought I could at least understand how it's 
> working, and right now I don't!
> Once again, this all has worked fine for a long time, and then something 
>  has changed in the environment or whatever, and now it doesn't work 
> right anymore on this server (but it does still work perfectly on my 
> laptop).
> Here's the SVG:
> ---------------------
>     <svg:svg
>     xmlns:svg="http://www.w3.org/2000/svg"
>         version="1.2"
>         height="85"
>         width="150"
>       >
>       <svg:rect x="0" y="0" width="150" height="85" fill="#d0d0d0"/>
>       <svg:flowRoot
>           fill="black"
>           font-size="30"
>           font-family="inkburrow"
>         >
>         <svg:flowRegion
>             vertical-align="middle"
>           >
>           <svg:rect x="0" y="0" width="150" height="85"/>
>         </svg:flowRegion>
>         <svg:flowDiv>
>           <svg:flowPara>
>              Some Text...
>           </svg:flowPara>
>         </svg:flowDiv>
>       </svg:flowRoot>
>     </svg:svg>
> (In real life this is an XSLT stylesheet, and the text comes from a 
> parameter to the stylesheet).
> I'm using Batik 1.6 supplied with a Cocoon distribution, with Saxon 8. I 
> tried upgrading to Batik 1.7, but got an NPE when I tried to run it 
> (sorry, don't have the exception stack trace anymore... I went back to 
> Batik 1.6 so I could demo this problem)
> If anybody could help shed some light on this, I'd really appreciate it!
> thanks,
> —ml—

To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org

View raw message