xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Kolesnikov ...@sundraw.ws>
Subject Re: Problem with xlink namespace?
Date Sat, 01 Apr 2006 18:09:22 GMT
Thanks a lot, Thomas, I've got it!

Alexander

thomas.deweese@kodak.com wrote:

>Hi Alexander:
>
>Alexander Kolesnikov <ak@sundraw.ws> wrote on 04/01/2006 12:46:43 PM:
>
>  
>
>>I suspect that the problem is in how I am dealing with XLink namespace, 
>>    
>>
>
>    Yes, this is your problem.
>
>  
>
>>// I need to add the XLink namespace, so this is how I am trying to do 
>>    
>>
>that
>  
>
>>root.setAttributeNS("xmlns", "xlink", "http://www.w3.org/1999/xlink");
>>    
>>
>
>   This does nothing for dom (and the first arg should be
>the XML namespaces namespace).  This can be helpful for serialization
>but the 'xlink' should be "xmlns:xlink" in that case.
>
>  
>
>>textPath.setAttributeNS("xlink", "href", "path0");
>>    
>>
>
>This needs to be:
>        textPath.setAttributeNS("http://www.w3.org/1999/xlink",
>                              "xlink:href", "path0");
>
>   The namespace arg is the namespace URI not the 'prefix'.
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
>For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org
>
>
>
>
>  
>



---------------------------------------------------------------------
To unsubscribe, e-mail: batik-users-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-users-help@xmlgraphics.apache.org


Mime
View raw message