xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fayyad, Elias" <efay...@netmap-us.com>
Subject RE: problem printing images embedded in SVG file
Date Tue, 14 May 2002 14:30:54 GMT
Hello again!
With Batik 1.5 beta 2 being out, I thought I'd check if my printing problem
went away.  Unfortunately not...
 
I compiled the beta 2 source code using JDK 1.4, and the rasterized a
Graphics2D object I had into an SVG document.  I then loaded that SVG
document into Batik's svgbrowser.  Loads perfectly fine, images and all.
However, when I print the document (from the svgbrowser) the text and lines
are there, but no images.
 
Could somebody out there help me out, please, by possibly loading the
attached SVG doc into their batik svgbrowser and see if the images print out
on your end?
 
Thanks, in advance, for your help.  And apologies for the attachment....
Elias.
 
P.S.  Is there someway for me to turn validation off, when reading the SVG
doc in Batik?  It seems that if I don't have an internet connection, I
cannot load the SVG doc at all......

____________________________________________________________________


-----Original Message-----
From: Fayyad, Elias [mailto:efayyad@netmap-us.com]
Sent: Tuesday, May 07, 2002 11:57 AM
To: 'batik-users@xml.apache.org'
Subject: problem printing images embedded in SVG file


Greetings,
 
I am relatively new to Batik, but the results that I've experienced in the
short amount of time I've used it have been fantastic!  I started out with
Batik 1.1.1, using JDK 1.3.  When 1.5beta1 came out, I got that.  Everything
was working great!  Then I switched to JDK 1.4 and then I had a printing
problem...  Let me set up the scenario.
 
I have a JFrame with a Graphics2D object on it, containing rendered images,
lines, and text.  I use the Batik rasterizer to create an SVG out of the
Graphics2D object.  The SVG file renders fabulously on the JSVGCanvas (both
in my app as well as the svgbrowser app included in the Batik distribution).
When I print (out of my app as well as from the svgbrowser), I get all my
lines and text, but no images at all...  FYI, I've used the
CachedImageHandlerBase64Encoder class to encode my images into the SVG file.
And as I've stated earlier, the file renders with no problems, using various
SVG viewers.  The problem occurs when printing.
 
So here's what I tested:

1. Batik 1.5 beta1
    svgbrowser,

    jdk 1.4, result: prints no images (only lines and text) 
    jdk 1.3, result: prints everything ok. 
2. Batik 1.1.1
    svgbrowser,

    jdk 1.4, result: prints no images (only lines and text) 
    jdk 1.3, result: prints everything ok. 
3. Batik 1.0
    svgbrowser,

    jdk 1.4, result: PRINTS EVERYTHING OK!!! 
    jdk 1.3, result: prints everything ok.
 
Any ideas?  I managed to get around the problem (in a really dirty way, for
the time being) by using the 1.5 svg generator with the 1.0 libs
(particularly the transcoders).  But that's not something I really want to
use...  Is this a problem with the JDK 1.4, Batik, or a combination of both?
 
Thanks in advance for any insights...
Elias.
 
 
 


Mime
View raw message