xmlgraphics-batik-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephane Hillion <shill...@ilog.fr>
Subject Re: Adobe SVGViewer doesn't like font-family:sansserif.italic without apos
Date Tue, 14 Aug 2001 16:44:44 GMT
On Tuesday 14 August 2001 18:18, Randall Parker wrote:
> It appeas that Adobe's SVGViewer considers this line to be bad because of
> the .italic as part of the font family name:
>         <font-face ascent="100.52667" descent="21.970367"
> units-per-em="100" style="font-family:sansserif.italic; font- style:italic;
> font-weight:normal;" />
> Changing to
>    font-family:sansserif;
>  removes the bad CSS error that I reported:
>      bad CSS property or descriptor declaration
> I noticed something else too. There were three occurrences of
> sansserif.italic. The later 2 were in text tags:
> <text x="227.9677734375" y="254.92665100097656" style="font-size:12;
> font-family:&apos;sansserif.italic&apos;; font-style:italic; stroke:none;">
> Note that they have the ampersand apostrophes around them. So then I
> changed the font-face font-family attribute to have the ampersand
> apostrophe
>         <font-face ascent="100.52667" descent="21.970367"
> units-per-em="100" style="font-family: &apos;sansserif.italic&apos;;
> font-style:italic; font-weight:normal;" />
> Now SVGViewer no longer generates an error message about this SVG file.
> So is it a bug in Batik for the font-face font-family to not put the apos
> chars around a font family that has a dot in the middle of it?

It seems to be a bug in SVGViewer.
See http://www.w3.org/TR/REC-CSS2/fonts.html#propdef-font-family for details 
about font name quoting rules.

> Oh, and btw, I still can't see the document in the IE plug-in Adobe
> SVGViewer. It emits no error. It just shows a white blank background.

To unsubscribe, e-mail: batik-users-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-users-help@xml.apache.org

View raw message