xmlgraphics-batik-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KuiLIU (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BATIK-1221) Inconsistent method name
Date Sat, 21 Apr 2018 19:03:00 GMT
KuiLIU created BATIK-1221:

             Summary: Inconsistent method name
                 Key: BATIK-1221
                 URL: https://issues.apache.org/jira/browse/BATIK-1221
             Project: Batik
          Issue Type: Improvement
            Reporter: KuiLIU

The following method is names as "convertOverflow", but the method does convert any 'Overflow'
but just checks whether the element 'e' is overflow or not.
Thus, the method name should be "isOverflow".

 public static boolean convertOverflow(Element e) {
        Value v = getComputedStyle(e, SVGCSSEngine.OVERFLOW_INDEX);
        String s = v.getStringValue();
        return (s.charAt(0) == 'h') || (s.charAt(0) == 's');

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: batik-dev-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-dev-help@xmlgraphics.apache.org

View raw message