xmlgraphics-batik-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank Lyaruu" <flya...@gmail.com>
Subject Re: problems with beginElement() in java
Date Sun, 23 Dec 2007 02:08:13 GMT
I thought that bug was fixed. Are you using the latest development version?

regards Frank

On Dec 23, 2007 1:40 AM, <cits@sinapto.net> wrote:

> hi all
> I'm using an animation, defined in the svg,  set to indefinite
>
>  <animateTransform id="anim"   begin="indefinite"   dur="6s"
> repeatCount="indefinite"       attributeName="transform"
>     attributeType="XML" type="rotate"
>        from="0 360 170" to="-90"       restart="always"/>
>
> It works (with begin="0s" ) but I cannot trigger begin and end.
>
> I want it to start when a certain event occurs, using java
> this is the code in the event listener:
>
>  Element elt = document.getElementById("anim");
>  boolean res=((SVGAnimationElement)elt).beginElement();
>
> even though res is true, the animation doesn't begin.
> this seems the same bug reported in:
>
>
> http://mail-archives.apache.org/mod_mbox/xmlgraphics-batik-users/200704.mbox/%3cBAY124-W8722283C86B8249D83721A75E0@phx.gbl%3e
>
> and
>
> http://issues.apache.org/bugzilla/show_bug.cgi?id=42487
>
> What can I do?
> is this a bug? Am I using the wrong method?
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-dev-unsubscribe@xmlgraphics.apache.org
> For additional commands, e-mail: batik-dev-help@xmlgraphics.apache.org
>
>
>

Mime
View raw message