xmlgraphics-batik-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Heuer <heue...@acm.org>
Subject Re: Maven artifacts for Batik
Date Tue, 11 Dec 2007 07:20:44 GMT
Cameron McCormack wrote:

> Hi Michael.
>
> Cameron McCormack:
> > > [unnecessary dependencies in batik maven poms]
>
> Michael Heuer:
> > I'm sorry, it's not as bad as I made it out to be.
> >
> > <snip>
> >
> > With batik-transcoder 1.6-1 compile and no runtime dependencies, I get
> > test failures with jdk 1.6.0_03, such as:
>
> Do you mean running the Batik test suite?  Or trying your own tests?

Local unit tests.  The project source repository is at

http://dishevelled.org/iconbundle/source-repository.html


> > So my list of exclusions would be
> >
> > avalon-framework	avalon-framework	4.0
> > batik	batik-1.5-fop	0.20-5
> > batik	batik-gui-util	1.6-1
> > fop	fop	0.20.5
> > xalan	xalan	2.4.1
>
> I'm not sure I can exclude avalon-framework, since FOP needs it, even
> just for the PDF transcoding classes.  Also, xalan is needed for Batik's
> DOM 3 XPath support.

Those are the exclusions I need to make in my pom, since I depend on only
a portion of batik's functionality.


> I'll publish some test POMs before the release and get you to test them,
> if you don't mind.

That would be great, thanks.

   michael


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-dev-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-dev-help@xmlgraphics.apache.org


Mime
View raw message