xmlgraphics-batik-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thomas.dewe...@kodak.com
Subject Re: Bundled Xerces
Date Tue, 05 Sep 2006 10:02:12 GMT
Hi Cameron,

Cameron McCormack <cam@mcc.id.au> wrote on 09/04/2006 09:25:54 PM:

> Thomas DeWeese:
> > The Xerces dependency is configurable (simply requires a SAX 2 
> > interface, and has recently moved to JAXP).
> 
> I forget: what is Xerces needed for?  Is it just the SAX parser, because
> Java 1.3 didn?t come with one?

   Yes, this is all that it is needed for.

> I wonder if we shouldn?t provide two distributions, one which includes
> Xerces (and Xalan, for XPath) to work on Java 1.3, and another that
> doesn?t, since Java 1.4 already has them.

   Well, so this raises an interesting question.  Right now our
code base will compile with either JDK 1.4 or 1.3 but you don't
get the same thing when you do this.  Will a JDK 1.4 build run 
cleanly on JDK 1.3?  I would suspect not since the JGVTComponent
will try and register a scroll wheel event handler which doesn't
exist in JDK 1.3.

   This is fine for development/source dist since the build
tools figure this all out for us, but what about when we go
to make a binary distribution?  I think it would be fairly ugly to
have two binary distributions (one for JDK 1.3, and one for
JDK 1.4+).  Is that commonly done?


---------------------------------------------------------------------
To unsubscribe, e-mail: batik-dev-unsubscribe@xmlgraphics.apache.org
For additional commands, e-mail: batik-dev-help@xmlgraphics.apache.org


Mime
View raw message