xmlgraphics-batik-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Hardy <vincent.ha...@sun.com>
Subject Re: static/threading problem with SVGFontUtilities
Date Wed, 20 Feb 2002 22:47:55 GMT
Keiron,

I see the problem for which you have a fix (DOMException) running your
test, but I am unable to reproduce the NullPointerException.

Would you have a complete trace of that Exception?

Thanks,
Vincent.

Keiron Liddle wrote:
> 
> Hi Vincent,
> 
> The memory thing is better thanks. It appears there can still be some
> threading thing but it is very rare (after about 12000 documents in heavy
> use).
> java.lang.NullPointerException
>         at org.apache.batik.bridge.SVGFontUtilities.getFontFamily(Unknown
> Source)
> 
> Using the testing that I sent in this email:
> http://marc.theaimsgroup.com/?l=batik-dev&m=100860672129140&w=2
> Is the way the code works valid?
> 
> The problem that I encountered there (the style parsing error) I was able
> to solve by putting a static synchronization around the lines 402 - 404 in
> CSSOMStyleDeclaration.
> 
> Thanks,
> Keiron.
> 
> On 2002.02.20 22:49 Vincent Hardy wrote:
> > Keiron,
> >
> > There is a fix in the CVS repository.
> > Cheers,
> > V.
> >
> > Keiron Liddle wrote:
> > >
> > > Hi,
> > >
> > > I have a couple of problems with the SVGFontUtilities class.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-dev-unsubscribe@xml.apache.org
> For additional commands, e-mail: batik-dev-help@xml.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-dev-help@xml.apache.org


Mime
View raw message