xmlgraphics-batik-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keiron Liddle <kei...@aftexsw.com>
Subject Re: static/threading problem with SVGFontUtilities
Date Thu, 21 Feb 2002 08:02:31 GMT
Hi Vincent,

No. It is a new BridgeContext every time a document is processed.
I had a look at it and it seems to me that the problem could be:
In BridgeContext
One thread is at line 225, so that thread knows the fontFamilyMap is not 
null.
Another thread then goes through line 250 and sets the fontFamilyMap to 
null. Since fontFamilyMap is static and common to both threads.
The first thread then returns null.

Keiron.

On 2002.02.21 04:19 Vincent Hardy wrote:
> Keiron,
> 
> Are you sharing your BridgeContext between threads by
> any chance? I think somehow the BridgeContext used by SVGFontUtilities
> is used by another thread which must set the context's Document
> in the middle of the getFontFamilyMap execution which then returns
> null.
> 
> Vincent.
> 
> Keiron Liddle wrote:
> >
> > It seems a bit rarer than I thought.
> >
> > Stack trace with line numbers:
> >
> ...
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: batik-dev-unsubscribe@xml.apache.org
> For additional commands, e-mail: batik-dev-help@xml.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: batik-dev-help@xml.apache.org


Mime
View raw message