xmlbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wing Yew Poon <wing.yew.p...@oracle.com>
Subject RE: XML-BEANS compiled schema: Incompatible minor version - expecting up to 23, got 24
Date Fri, 23 Oct 2009 18:25:24 GMT
Well, the error message is pretty clear.
The xmlbeans your runtime is using has an earlier version than
the version of xmlbeans used to compile your schema.
You can use schema jars compiled with older versions of xmlbeans 
than your runtime, but not with newer. The situation is analogous
to that of java classes and the jdk.
Clearly, weblogic 9x shipped with a version of xmlbeans that is
earlier than 2.4. Consult your weblogic documentation or experts
on how to use a different version of apache xmlbeans than is shipped
with the product. (Weblogic also uses a com.bea-repackaged version
of xmlbeans internally; you should not replace this xmlbeans.)
- Wing Yew

-----Original Message-----
From: jh10a957 [mailto:rakeshkumar.singh@gmail.com] 
Sent: Friday, October 23, 2009 11:02 AM
To: user@xmlbeans.apache.org
Subject: XML-BEANS compiled schema: Incompatible minor version - expecting up to 23, got 24


I was using xmlbean2.2 and upgraded to xmlbean2.4. Compilation of schema jars
are fine but while deploying in Weblogic 9.2 I am getting the exception as
below.
Anyone else facing the same issue?

Caused by: java.lang.RuntimeException: Could not instantiate
SchemaTypeSystemImpl (java.lang.reflect.InvocationTargetException): is the
version of xbean.jar correct?
at
schemaorg_apache_xmlbeans.system.sD10023A5BF0E00636EB8A1FCB541F982.TypeSystemHolder.loadTypeSystem(Unknown
Source)
at
schemaorg_apache_xmlbeans.system.sD10023A5BF0E00636EB8A1FCB541F982.TypeSystemHolder.<clinit>(Unknown
Source)
... 43 more
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
... 45 more
Caused by: org.apache.xmlbeans.SchemaTypeLoaderException: XML-BEANS compiled
schema: Incompatible minor version - expecting up to 23, got 24
(schemaorg_apache_xmlbeans.system.sD10023A5BF0E00636EB8A1FCB541F982.index) -
code 3
at
org.apache.xmlbeans.impl.schema.SchemaTypeSystemImpl$XsbReader.<init>(SchemaTypeSystemImpl.java:1522)
at
org.apache.xmlbeans.impl.schema.SchemaTypeSystemImpl.initFromHeader(SchemaTypeSystemImpl.java:260)
at
org.apache.xmlbeans.impl.schema.SchemaTypeSystemImpl.<init>(SchemaTypeSystemImpl.java:183)
... 49 more^^ 
 
 


-- 
View this message in context: http://www.nabble.com/XML-BEANS-compiled-schema%3A-Incompatible-minor-version---expecting-up-to-23%2C-got-24-tp26030820p26030820.html
Sent from the Xml Beans - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: user-help@xmlbeans.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: user-help@xmlbeans.apache.org


Mime
View raw message