xmlbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pete Cordell" <petexml...@codalogic.com>
Subject Re: Suppress prefix validation in the XML -Message
Date Sat, 25 Jul 2009 19:34:58 GMT
Would it help if you posted the XSD schema?

Thanks,

Pete Cordell
Codalogic Ltd
Visit http://codalogic.com/lmx/ or http://www.xml2cpp.com
for C++ XML data binding
----- Original Message ----- 
From: "Henry A" <henry_human@yahoo.de>
To: <user@xmlbeans.apache.org>
Sent: Saturday, July 25, 2009 7:16 PM
Subject: Re: Suppress prefix validation in the XML -Message




>from what you describe it sounds like you might have a validation
a)
The only message after validating of response i get is a boolean value:false

//hier is the validation
responseDoc.Factory.parse(respons_decoded).validate();
Are there other options to get more validation data from the xmlbean!?

b)
I do not understand what you mean, they are total different messages??
The message 1 you see below is the original response
The message 2 is the original response after i removed the prefixes
??
strange enough, after removing the ns1: from tags, xmlbeans does process
 the response fine but still the validation value of document is false!

??
-----------------------------



Jacob Danner-2 wrote:
>
> from what you describe it sounds like you might have a validation
> issue with the instance. Have you tried validating and seen if there
> are errors?
>
> This:
> <response    xmlns="http://kkk/schema/xsxs"
> xmlns:ns1="http://kkk/xsx.org/">
>     <ns1:something>
>     <ns1:mn> and so on</ns1:mn>
>     </ns1:something>
> </response>
>
> compared to this:
> <response    xmlns="http://kkk/schema/xsxs"
> xmlns:ns1="http://kkk/xsx.org/">
>     <something>
>     <mn> and so on</mn>
>     </something>
>   </response>
>
> are actually quite different.
> If you still need help, please let us know what the validation errors are.
>
> -jacobd
>
>
> On Sat, Jul 25, 2009 at 6:41 AM, Henry A<henry_human@yahoo.de> wrote:
>>
>> The message that my client gets from service looks lik this:
>> <response xmlns="http://kkk/schema/xsxs"
>> xmlns:ns1="http://kkk/xsx.org/">
>> <ns1:something>
>> <ns1:mn> and so on</ns1:mn>
>> </ns1:something>
>> </response>
>>
>> Because the prefix ns1 is used in the message, the xmlbenas in client
>> fails
>> with an error!
>> But when I remove the prefix from xml response and then handover to the
>> xmlbean works fine.
>> How can I say xmlbeans to understand the prefix in the message?
>> Thanks for your hint in advance.
>>
>>
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Suppress-prefix-validation-in-the-XML--Message-tp24658040p24658040.html
>> Sent from the Xml Beans - User mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
>> For additional commands, e-mail: user-help@xmlbeans.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
> For additional commands, e-mail: user-help@xmlbeans.apache.org
>
>
>

-- 
View this message in context: 
http://www.nabble.com/Suppress-prefix-validation-in-the-XML--Message-tp24658040p24660279.html
Sent from the Xml Beans - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: user-help@xmlbeans.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: user-help@xmlbeans.apache.org


Mime
View raw message