xmlbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johnnyrok <john-adsul.ander...@virgin.net>
Subject Error running scomp
Date Sun, 17 Sep 2006 06:08:53 GMT

Regarding the FAQ "error running scomp"
 
http://mail-archives.apache.org/mod_mbox/xmlbeans-user/200607.mbox/%3cF91503BC8AA6384BA2FFED03EF8E392C0146BB78@repbex01.amer.bea.com%3e
 
I modified the 'scomp.cmd' script, to ref JAVA_HOME directly {set
cp=%cp%;%JAVA_HOME%\bin"}, and subsequently got the following error on XP:
 
C:\xmlbeans-2.2.0\example>scomp -out Po.jar Po.xsd
 
Exception in thread "main" Java.lang.NoClassDefFoundError:
Files\j2sdk1/4/2_12\l
Ib\tools/jar;C:\xmlbeans-2/2/0\lib\resolver/jar
org/Apache/xmlbeans/impl/tool/Sc
HemaCompiler -out Po/jar Po/xsd
C:\xmlbeans-2.2.0\example>

My JDK is installed under "C:\Program Files\j2sdk1.4.2_12". From the above,
it is clear that javac is not the issue, rather, the classpath entry to the
tools.jar is incorrect. I'm guessing the classpath is parsed by the xbeans
tool, before invoking javac itself.

Environment:
JAVA_HOME=C:\Program Files\j2sdk1.4.2_12
OS=Windows_NT
Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program
Files\j2
sdk1.4.2_12;C:\Program
Files\j2sdk1.4.2_12\bin;C:\apache-ant-1.6.5\bin;C:\Progra
m Files\Apache Group\Tomcat 4.1;C:\xmlbeans-2.2.0\bin;
 
One (undesirable) way around this would be to re-install the JDK to
somewhere other than "C:\Program Files".
-- 
View this message in context: http://www.nabble.com/Error-running-scomp-tf2284760.html#a6346761
Sent from the Xml Beans - User forum at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: user-help@xmlbeans.apache.org


Mime
View raw message