xmlbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lawrence Jones" <ljo...@bea.com>
Subject RE: xmlbeans ant task
Date Tue, 16 Aug 2005 21:41:25 GMT
Here's the patch to the docs I was referring to below.

Cheers,

Lawrence

> -----Original Message-----
> From: Lawrence Jones
> Sent: Tuesday, August 16, 2005 10:07 AM
> To: 'user@xmlbeans.apache.org'
> Subject: RE: xmlbeans ant task
> 
> Hi all
> 
> I'm going to submit a patch that will update the documentation to
include
> jsr173_api.jar in the classpath.
> 
> The UnsupportedClassVersionError is odd - the only circumstance when
you
> would get that appears to me to be if you had already compiled
> org/apache/xmlbeans/xml/stream/XMLInputStream.java using a jdk 1.5
javac
> and then try to recompile some other part of the source code using jdk
> 1.4.x which depends on XMLInputStream and ends up picking up the
> org.apache.xmlbeans.xml.stream.XMLInputStream.class file which you
> compiled with jdk 1.5. Then the class file could have a "later" format
> which the 1.4.x javac doesn't understand.
> 
> It could be an error in the 'clean' target not deleting
> org.apache.xmlbeans.xml.stream.XMLInputStream.class before starting
the
> compile. If one of you could send me a repro containing the exact
steps
> you took (you can send this to me offline if you like) then I'll raise
a
> JIRA for it and we can get it looked at.
> 
> Cheers,
> 
> Lawrence
> 
> > -----Original Message-----
> > From: Oakes, Jeff (HTSC, IT) [mailto:Jeff.Oakes@htsco.com]
> > Sent: Tuesday, August 16, 2005 9:42 AM
> > To: 'user@xmlbeans.apache.org'
> > Subject: RE: xmlbeans ant task
> >
> > I had the same experience with j2sdk1.4.2_06
> >
> > later,
> >
> > Jeff
> >
> >
> > -----Original Message-----
> > From: maarten [mailto:maartenb@dns.be]
> > Sent: Wednesday, August 10, 2005 5:06 AM
> > To: user@xmlbeans.apache.org
> > Subject: Re: xmlbeans ant task
> >
> >
> > maarten wrote:
> >
> > > Hi,
> > >
> > > Using xmlbeans-1.0.4  I can compile and use my schema with
jdk1.5.0_03
> > > but when I try compiling with j2sdk1.4.2_08
> > > I get the following error:
> > > java.lang.UnsupportedClassVersionError:
> > > org/apache/xmlbeans/xml/stream/XMLInputStream (Unsupported
major.minor
> > > version 49.0)
> > >
> > > Using xmlbeans-2.0.0 I can compile with both jdk1.5.0_03 and
> > > j2sdk1.4.2_08
> > > BUT i had to add jsr173_api.jar to the classpath of both the
taskdef
> > > and the xmlbean task:
> > >
> > > I guess the examples on
> > > http://xmlbeans.apache.org/docs/2.0.0/guide/antXmlbean.html are
> > > incomplete ?
> > >
> > > This is my build.xml :
> > >
> > > <project name="vapschema" basedir="." default="vapschema">
> > >  <target name="init">
> > >    <mkdir  dir="gen/xbeans"/>
> > >    <mkdir  dir="build/xbeans/classes"/>
> > >    <tstamp/>
> > >  </target>
> > >  <target name="vapschema" depends="init"  description="Compiles
> > > vap.xsd with xmlbeans">
> > >    <taskdef name="xmlbean"
> > > classname="org.apache.xmlbeans.impl.tool.XMLBean"
> > >      classpath="./jars/xbean-2.0.0.jar:./jars/jsr173_api.jar"/>
> > >    <xmlbean
> > >      schema="./src/be/sunrise/vap/vap.xsd"
> > >      classgendir="build/xbeans/classes"
> > >      srcgendir="gen/xbeans"
> > >      destfile="build/vap-schema.jar"
> > >      classpath="./jars/xbean-2.0.0.jar:./jars/jsr173_api.jar"/>
> > >  </target>
> > > </project>
> > >
> > > Maarten
> > >
> > >
---------------------------------------------------------------------
> > > To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
> > > For additional commands, e-mail: user-help@xmlbeans.apache.org
> > >
> > >
> > Is nobody else using the ant task ?
> >
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@xmlbeans.apache.org
> > For additional commands, e-mail: user-help@xmlbeans.apache.org
> >
> >
> >
> >
>
************************************************************************
*
> > PRIVILEGED AND CONFIDENTIAL: This communication, including
attachments,
> is
> > for the exclusive use of addressee and may contain proprietary,
> > confidential and/or privileged information.  If you are not the
intended
> > recipient, any use, copying, disclosure, dissemination or
distribution
> is
> > strictly prohibited.  If you are not the intended recipient, please
> notify
> > the sender immediately by return e-mail, delete this communication
and
> > destroy all copies.
> >
>
************************************************************************
*



Mime
View raw message