xmlbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lance Robertson <lance.robert...@jda.com>
Subject RE: Index.xsb file
Date Thu, 12 Feb 2004 17:38:04 GMT
Ok, after walking through the source code again and putting in some print
lines I was finally able to find my problem. The index.xsb gets put into the
xmltypes.jar file but evidently I'm not generating one due to the way I have
setup the compile. I put in my ant task 

	<target name="schema" if="xsd" description="Generates Java files
based on schema">
		<xmlbean srcgendir="${gen.src.dir}"
classgendir="${classes.dir}" failonerror="true">
			<fileset dir="${schema.dir}" includes="**/*.*"/>
		</xmlbean>
	</target>

But I get about 100 errors upon building saying "package org.apache.xmlbeans
does not exist". Before I was merely generating the source files (as I
thought that generated all that I needed but that doesn't seem to be the
case). 

	<target name="schema" if="xsd" description="Generates Java files
based on schema">
		<xmlbean srcgendir="${gen.src.dir}" srconly="true"
failonerror="true">
			<fileset dir="${schema.dir}" includes="**/*.*"/>
		</xmlbean>
	</target>


Is there a way to generate all needed files but allow my compile tag in ant
to build everything? I think this will solve my problem if I could get all
the xsb files generated without compiling everything but I don't even know
if that is possible.

Thanks,

Lance


-----Original Message-----
From: Lance Robertson [mailto:lance.robertson@jda.com] 
Sent: Thursday, February 12, 2004 6:41 AM
To: 'xmlbeans-user@xml.apache.org'
Subject: Index.xsb file


Hello all...

I'm am having a bugger of a problem with this index.xsb file. It keeps
telling me there should be an index.xsb file under
schema\system\sA2D1A7E239AD9DCB87A48FDC362C6133 where the generated schema
code is. But I cannot find one either in my real code or my prototype and
the prototype runs just fine. Does anyone know about this file? Why is the
org.apache.xmlbeans.impl.schema.SchemaTypeSystemImpl$XsbReader class trying
to read this file that doesn't seem to exist. Any help would be greatly
appreciated. I know now that it isn't a class loader problem as I the jar
file is in our manifest path and we do have access to it. Just for some
reason it's wanting to read this file that doesn't exist.

Thank you in advance

- ---------------------------------------------------------------------
To unsubscribe, e-mail:   xmlbeans-user-unsubscribe@xml.apache.org
For additional commands, e-mail: xmlbeans-user-help@xml.apache.org Apache
XMLBeans Project -- URL: http://xml.apache.org/xmlbeans/

- ---------------------------------------------------------------------
To unsubscribe, e-mail:   xmlbeans-user-unsubscribe@xml.apache.org
For additional commands, e-mail: xmlbeans-user-help@xml.apache.org
Apache XMLBeans Project -- URL: http://xml.apache.org/xmlbeans/


Mime
View raw message