xmlbeans-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Perham (JIRA)" <xmlbeans-...@xml.apache.org>
Subject [jira] Created: (XMLBEANS-332) XMLBeans changes surrogate pair bytes to question marks
Date Wed, 30 May 2007 15:11:16 GMT
XMLBeans changes surrogate pair bytes to question marks
-------------------------------------------------------

                 Key: XMLBEANS-332
                 URL: https://issues.apache.org/jira/browse/XMLBEANS-332
             Project: XMLBeans
          Issue Type: Bug
    Affects Versions: Version 2.2
            Reporter: Mike Perham
         Attachments: XMLBEANS-332.zip

I can't debug this problem because I can't find the 2.2.0 source code anywhere and XMLBeans
does not appear to have any commons-logging which I can turn on.  So I'm just throwing what
I have into this issue, hoping that an XMLBeans developer can look at the problem more in-depth.

The attached zip file contains an xml file with Unicode surrogate pairs - these pairs are
a notoriously hard Unicode edge case to handle.  XMLBeans appears to be turning pairs into
question marks when emitting the XMLBean using the xmlText or toString methods.

The attachment contains a JUnit test case which reproduces the problem on XMLBeans 2.2.0.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: dev-help@xmlbeans.apache.org


Mime
View raw message