xmlbeans-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Danner" <jacob.dan...@gmail.com>
Subject Re: org.apache.xmlbeans.XmlException: Element is not valid
Date Wed, 14 Mar 2007 18:56:59 GMT
Hi Ramesh,
This looks like it might be an expected error.

My guess is that when you call:

TemplateDocument.Factory.parse()

you are passing content that starts with
<xsd:schema ... />
rather than
<Template ... />

Can you confirm this is the case?

-Jacobd
On 3/14/07, Ramesh Ranganathan <ramesh.xb@gmail.com> wrote:
> Hi,
>
> I am getting the following exception when I try to run my program.
>
> C:\Projects\SRS\Programs\xmlbeans\EasyPO>java Template
> org.apache.xmlbeans.XmlException: Element
> schema@http://www.w3.org/2001/XMLSchema is not a valid
> Template@Template document or a valid substitution.
>         at
> org.apache.xmlbeans.impl.store.Locale.autoTypeDocument(Locale.java:322)
>         at
> org.apache.xmlbeans.impl.store.Locale.parseToXmlObject
> (Locale.java:1273)
>         at
> org.apache.xmlbeans.impl.store.Locale.parseToXmlObject(Locale.java:1257)
>         at
> org.apache.xmlbeans.impl.schema.SchemaTypeLoaderBase.parse(SchemaTypeLoaderBase.java:345)
>         at
> org.apache.xmlbeans.impl.schema.SchemaTypeLoaderBase.parse(SchemaTypeLoaderBase.java:252)
>         at template.TemplateDocument$Factory.parse(Unknown
> Source)
>         at Template.main(Template.java:15)
> Exception in thread "main" java.lang.NullPointerException
>         at Template.main(Template.java:23)
>
> Please help me on this.
>
> Regards,
> Ramesh Kumar.R

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: dev-help@xmlbeans.apache.org


Mime
View raw message