xmlbeans-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Danner (JIRA)" <xmlbeans-...@xml.apache.org>
Subject [jira] Commented: (XMLBEANS-315) javac not found properly, couldn't find internet help
Date Thu, 08 Mar 2007 00:49:24 GMT

    [ https://issues.apache.org/jira/browse/XMLBEANS-315?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12479180
] 

Jacob Danner commented on XMLBEANS-315:
---------------------------------------

hmm, 
what javac errors were you seeing?
I think the problem is that sometimes %JAVA_HOME% will use windows 8.3 names versus the true
absolute path.
I've confirmed that 8.3 paths work.

I've added the following to the wiki and will be resolving the issue unless you have further
suggestions.
Wiki content addition:
If that doesn't fix the issue, try specifying path using Windows 8.3 names. This will get
around issues with spaces in folder names.

> javac not found properly, couldn't find internet help
> -----------------------------------------------------
>
>                 Key: XMLBEANS-315
>                 URL: https://issues.apache.org/jira/browse/XMLBEANS-315
>             Project: XMLBeans
>          Issue Type: Bug
>    Affects Versions: Version 2.2
>         Environment: Windows XP sp2
>            Reporter: Ben Leedham
>            Priority: Minor
>             Fix For: Version 2.2
>
>
> Hi,
>  I have recently installed XML beans, it looks like an excellent tool. I installed version
2.2.0 on Windows. When trying to use scomp (scomp -out file.jar file.xsd) I was getting the
javac error. I made sure all my environment variables were in the correct place and still
got the error. I found some info in the FAQ about using %JAVA_HOME%\bin\java, again I edited
the scomp.cmd file and swapped this line:
> java -classpath "%cp%" org.apache.xmlbeans.impl.tool.SchemaCompiler %*
> For this line:
> %JAVA_HOME%\bin\java -classpath "%cp%" org.apache.xmlbeans.impl.tool.SchemaCompiler %*
> I then received an error saying that "'C:\Program' is not recognized as an internal or
external command, operable program or batch file."
> I realised this was because my JDK was in "Program Files", I tried encasing my Environment
Variables in quotes but to no avail. Eventually after much internet searching I tried typing
into the scomp.cmd this line:
> "%JAVA_HOME%\bin\java" -classpath "%cp%" org.apache.xmlbeans.impl.tool.SchemaCompiler
%*
> With quotes encasing the %JAVA_HOME% section.
> I realise this may not be the most pressing issue, but I found little help on the internet
and nothing to do with encasing the %JAVA_HOME%\bin\java with quotes, maybe it should be added
to the small section in the FAQ to do with the java issue.
> Thanks for your time.
> Regards,
> Ben

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xmlbeans.apache.org
For additional commands, e-mail: dev-help@xmlbeans.apache.org


Mime
View raw message