xml-xmlbeans-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "MONTGOMERY, ANDREW [AG-Contractor/1000]" <andrew.montgom...@monsanto.com>
Subject RE: XPath
Date Tue, 10 Aug 2004 15:03:57 GMT
Uwe,

Assuming, code is an attribute of language, you need the '@' before code. (ie. "./language[@code='sv']").


Cheers

Andrew

-----Original Message-----
From: Uwe Klosa [mailto:uwe.klosa@ub.uu.se]
Sent: Tuesday, August 10, 2004 9:57 AM
To: xmlbeans-dev@xml.apache.org
Subject: XPath


I've got a question about the support of XPath. I now have in my XPath both
xmlbean.jar and xmlbean_path.jar (V1.0.3).

An selectPath with an XPath like "./language" works fine. But if I change it
to "./language[code='sv']" where code is an element under language doesn't
return any results even if a node exists with this XPath. Is it not
supported yet. Have i to wait for V2?

Best regards
Uwe Klosa
__________________________________________________
Electronic Publishing Centre
Development
UPPSALA UNIVERSITY
University Library

Tel: +46 18 471 7658
Fax: +46 18 471 3913
E-mail: uwe.klosa@ub.uu.se
Homepage: http://publications.uu.se/



- ---------------------------------------------------------------------
To unsubscribe, e-mail:   xmlbeans-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xmlbeans-dev-help@xml.apache.org
Apache XMLBeans Project -- URL: http://xml.apache.org/xmlbeans/

- ---------------------------------------------------------------------
To unsubscribe, e-mail:   xmlbeans-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xmlbeans-dev-help@xml.apache.org
Apache XMLBeans Project -- URL: http://xml.apache.org/xmlbeans/


Mime
View raw message