xml-xmlbeans-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Danner" <jac...@bea.com>
Subject RE: Debugging SchemaCompiler errors
Date Mon, 12 Jan 2004 02:48:06 GMT
this usually occurs when the element is not qualified by the XML schema namespace.
if you can find the element, try adding the namespace prefix to it (usually xs or XSD.
Good luck,
-Jacobd

	-----Original Message----- 
	From: Frederick N. Brier [mailto:fbrier@multideck.com] 
	Sent: Sun 1/11/2004 2:58 PM 
	To: xmlbeans-dev@xml.apache.org 
	Cc: 
	Subject: Debugging SchemaCompiler errors
	
	

	Using the provided examples, my build file has an ant task to take a
	schema and generate the xmlbeans classes.  It did so with a simpler
	schema and some initial code used it to load an xml file from the file
	system.  However, an enhanced schema is generating the error message below:
	
	     [java] C:\src\conf\xml\myschema.xsd:0: error: Attribute not
	allowed: name in element complexType@http://www.w3.org/2001/XMLSchema
	
	Unfortunately that is the only output.  The schema validates using
	XmlSpy.  I have tried the -debug and -verbose SchemaCompiler command
	line parameters to generate a more detailed message.  As an aside, I
	have also tried these parameters: "-dl -repackage -noupa -nopvr
	-allowmdef".  Are there any suggestions for tracking down the problem? 
	I am using version xmlbeans 1, not CVS.  The schema is fairly involved
	(inheritance, complex mixed element types, etc), but I am not at liberty
	to post it.  Thank you for any assistance.
	
	Frederick N. Brier
	
	
	
	
	- ---------------------------------------------------------------------
	To unsubscribe, e-mail:   xmlbeans-dev-unsubscribe@xml.apache.org
	For additional commands, e-mail: xmlbeans-dev-help@xml.apache.org
	Apache XMLBeans Project -- URL: http://xml.apache.org/xmlbeans/
	
	

Mime
View raw message