xml-xalan-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Ludwig <mil...@gmx.de>
Subject Re: Use of Xalan 2.7.1 with Java JRE 6.0.05.
Date Mon, 22 Feb 2010 23:17:16 GMT
ajay bhadauria schrieb am 22.02.2010 um 10:34:00 (-0800):

> Xalan-J XSLT 2.7.1 and Xerces Schema 2.9.0 are supported on JDK/JRE
> 1.3.x, 1.4.x, or 5.x. This is from below Apache site. 
> 
> http://xml.apache.org/xalan-j/downloads.html
> 
> We would like to use Xalan 2.7.1 and xerces 2.9.0 with runtime Java
> version of Java JRE 6.0.05.

If you're using Sun's Java, it is practically a prerequisite for XML
processing to use Apache Xerces instead of the Sun implementation,
possibly by using the extension override mechanism.

The often-stated reason is that the implementation in Sun Java 1.6 is,
as a highly qualified authority put it, "ridiculously bug-ridden". So
don't use it. Use Apache Xerces, and Xalan, too, if you need it.

-- 
Michael Ludwig

Mime
View raw message