xml-xalan-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Moore, Gavin" <gavin.mo...@iona.com>
Subject Xalan Extensions - Endorsed Override
Date Tue, 13 May 2003 14:41:19 GMT
Hi,
I'm trying to get some extensions working with Xalan and JDK1.4, and it isn't working for
me.  I'm using one of the samples, 3-java-namespace, and I get the message below:
 
D:\xalan_2_5\xalan-j_2_5_0\samples\extensions>java org.apache.xalan.xslt.Process -in 3-java-namespace.xml
 -xsl 3-java-n
amespace.xsl
 
file:///D:/xalan_2_5/xalan-j_2_5_0/samples/extensions/3-java-namespace.xsl; Line #18; Column
#60; XSLT Error (javax.xml.
transform.TransformerException): javax.xml.transform.TransformerException: java.lang.ClassNotFoundException:
IntDate
 
I looked up the error and found that it should be solved by adding xalan.jar, xml-apis.jar
and xercesImpl.jar to the "endorsed" directory in the the lib directory of JAVA_HOME of the
JRE.  Incidentally, I had to create the endorsed directory.  After I added the jar files,
it appears to be looking for the correct version of Xalan, as I checked it with org.apache.xalan.xslt.EnvironmentCheck
and got the file attached, which shows the before and after adding the files.  However, I
still get the same error when I try to process the xml.  Does anyone have any other way to
do this?  I've also tried the Xbootclasspath option mentioned at http://xml.apache.org/xalan-j/faq.html#faq-N100CB,
but with similar lack of success.
 
Thanks,
Gavin.

Mime
View raw message