xml-xalan-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eoin Breathnach" <ebreathn...@www.eoinbreathnach.com>
Subject Re: Conditional assignment of tree frag to variable doesn't work.
Date Thu, 08 May 2003 08:29:23 GMT
How do I get taken off this mailing list?

Regards,

Eoin

---------- Original Message -----------
From: kroberts@mmm.com
To: xalan-j-users@xml.apache.org
Sent: Wed, 7 May 2003 17:58:55 -0600
Subject: Conditional assignment of tree frag to variable doesn't work.

> This is probably a simple question; but I've tried several things 
> and don't seem to be getting anywhere with this issue. I cannot get 
> the assignment to the variable SelectFilterX to work.  I'm trying to 
> get some old xalan-1 code to work in xalan 2.5.0.
> 
> <xsl:variable name="SelectFilterX">
>       <xsl:choose>
>         <xsl:when test="$Filter
> =$OSHProfile/default_filter/filter/field[1]">
>           <xsl:apply-templates select="$OSHProfile/default_filter/filter"/>
>         </xsl:when>
>         <xsl:otherwise>
>           <xsl:apply-templates select="$OSHProfile/quick_filters/*[field[1]
> =$Filter]"/>
>         </xsl:otherwise>
>       </xsl:choose>
>     </xsl:variable>
> 
>     <xsl:copy-of select="$SelectFilterX"/>
> 
> This doesn't copy anything. I tried copying OSHProfile and it copied 
> fine. OSHProfile is set in Java as a document element.
> 
> Keith...
------- End of Original Message -------


Mime
View raw message