xml-xalan-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mk...@ca.ibm.com
Subject Re: 2_2_D6 -> 2_4_0 xsl migration problem
Date Thu, 10 Oct 2002 14:17:45 GMT
Attributes can be converted to Strings automatically.  <xsl:value-of select
="@Code"> should work with both Xalan versions. If it is not working in
Xalan 2.4, please open a bug and attach your xml and xsl files to the bug
description.

Morris Kwan
XSLT Development
IBM Toronto Lab
Tel: (905)413-3729
Email: mkwan@ca.ibm.com



                                                                                         
                                           
                      "Anton Straka"                                                     
                                           
                      <anton_straka@abil        To:       <xalan-j-users@xml.apache.org>
                                            
                      itydev.com>               cc:                                   
                                              
                                                Subject:  2_2_D6 -> 2_4_0 xsl migration
problem                                      
                      10/10/2002 06:37                                                   
                                           
                      AM                                                                 
                                           
                                                                                         
                                           
                                                                                         
                                           



Hi.

I'm sorry for this question, but I didn't find answer on the mailing list.

I have a xsl, which was runing OK in the version 2_2_D6 version of xalan.
Now I try it again with 2_4_0 version and found problem. After some
introspection I found, that construction like

<xsl:value-of select"@Code">

must be replaced with

<xsl:value-of select"string(@Code)">

to ensure correct work.

I want to ask if it is bug or feature, that @something are not converted to
string automatically in string expression?

Thanks a lot.

anton



Mime
View raw message