xml-xalan-j-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koes, Derrick" <Derrick.K...@smith-nephew.com>
Subject Have we disobeyed a cardinal rule?
Date Mon, 07 Oct 2002 17:23:21 GMT
 

We are transforming XML to HTML using XSLT.  The problem is that some of the
values used to populate the HTML forms have quotes (' " ') in them.

These values seem to be in a fine state until they are used to populate HTML
input elements.  We don't URL encode/decode at the moment, but some
experimentation has shown that if the values are persisted as URL encoded
then are URL decoded and assigned to the appropriate elements AFTER the page
loads (e.g. in a onWindowLoad javascript method) things are OK.

 

We've also seen that this is only a problem when they are being assigned to
attributes, since attributes use quotes to enclose their values.

 

To summarize, it appears we will have to URL encode and URL decode all
individual values (encoding/decoding as XML does not work well) for our app
to use these values.  Is this correct?  Is there a better way to solve this
problem?

 

Thanks,

Derrick

This electronic transmission is strictly confidential to Smith & Nephew and
intended solely for the addressee.  It may contain information which is
covered by legal, professional or other privilege.  If you are not the
intended addressee, or someone authorized by the intended addressee to
receive transmissions on behalf of the addressee, you must not retain,
disclose in any form, copy or take any action in reliance on this
transmission.  If you have received this transmission in error, please
notify the sender as soon as possible and destroy this message.

Mime
View raw message