xml-xalan-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henry Zongaro (JIRA)" <xalan-...@xml.apache.org>
Subject [jira] Commented: (XALANJ-2243) <input type="text" SIZE="62" name="text1" value="{$temp} " /> disable-output-escaping="yes" is not working
Date Tue, 06 Dec 2005 15:18:09 GMT
    [ http://issues.apache.org/jira/browse/XALANJ-2243?page=comments#action_12359437 ] 

Henry Zongaro commented on XALANJ-2243:
---------------------------------------

According to section 16.4 of XSLT 1.0 [1]

«It is an error for output escaping to be disabled for a text node that is used for something
other than a text node in the result tree. Thus, it is an error to disable output escaping
for an xsl:value-of or xsl:text element that is used to generate the string-value of a comment,
processing instruction or attribute node... an XSLT processor may signal the error; if it
does not signal the error, it must recover by ignoring the disable-output-escaping attribute.»

In your original example, the text node that you've constructed is used to produce string
value of an attribute node in the result tree, which is an error according to section 16.4.

[1] http://www.w3.org/TR/xslt#disable-output-escaping

> <input type="text" SIZE="62" name="text1" value="{$temp} " /> disable-output-escaping="yes"
is not working
> ----------------------------------------------------------------------------------------------------------
>
>          Key: XALANJ-2243
>          URL: http://issues.apache.org/jira/browse/XALANJ-2243
>      Project: XalanJ2
>         Type: Bug
>   Components: Xalan
>     Reporter: sarajit ghosh

>
> <xsl:variable name="temp"><xsl:text  disable-output-escaping="yes"><![CDATA[&#1578;&#1606;&#1606;]]></xsl:text></xsl:variable>
> <input type="text" SIZE="62" name="text1" value="{$temp} " />
> disable-output-escaping="yes" is not working when we are assigning a unicode value to
a text box.
> here processor parse &#1578;&#1606;&#1606;
> So in browser desired output should be ???
> But it is coming &#1578;&#1606;&#1606;
> Can any one help me in this regard.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: xalan-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xalan-dev-help@xml.apache.org


Mime
View raw message