xml-xalan-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bertoni (JIRA)" <xalan-...@xml.apache.org>
Subject [jira] Commented: (XALANJ-2243) <input type="text" SIZE="62" name="text1" value="{$temp} " /> disable-output-escaping="yes" is not working
Date Mon, 05 Dec 2005 19:58:08 GMT
    [ http://issues.apache.org/jira/browse/XALANJ-2243?page=comments#action_12359339 ] 

David Bertoni commented on XALANJ-2243:
---------------------------------------

You seem to be misunderstanding what CDATA sections are, and what disable-output-escaping
accomplishes.  By placing what looks like numeric character references in a CDATA section,
you are telling the parser that they are not markup.  Given that, it's not surprising you're
not getting the characters you expect.

Since you haven't provided a complete example, it's hard to tell what output you are expecting,
but Xalan-J is behaving correctly from what I can see.  If you really want the three characters
U+062A (Arabic Letter Teh), U+0646 (Arabic Letter Noon), and U+0646 (Arabic Letter Noon),
then don't use a CDATA section:

<xsl:variable name="temp" select ="&#1578;&#1606;&#1606;"/>

Unless you can provide more information, I believe this is not a bug, and should be marked
invalid. In the future, you should ask questions on the user mailing list, rather than create
Jira issues.

> <input type="text" SIZE="62" name="text1" value="{$temp} " /> disable-output-escaping="yes"
is not working
> ----------------------------------------------------------------------------------------------------------
>
>          Key: XALANJ-2243
>          URL: http://issues.apache.org/jira/browse/XALANJ-2243
>      Project: XalanJ2
>         Type: Bug
>   Components: Xalan
>     Reporter: sarajit ghosh

>
> <xsl:variable name="temp"><xsl:text  disable-output-escaping="yes"><![CDATA[&#1578;&#1606;&#1606;]]></xsl:text></xsl:variable>
> <input type="text" SIZE="62" name="text1" value="{$temp} " />
> disable-output-escaping="yes" is not working when we are assigning a unicode value to
a text box.
> here processor parse &#1578;&#1606;&#1606;
> So in browser desired output should be ???
> But it is coming &#1578;&#1606;&#1606;
> Can any one help me in this regard.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: xalan-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xalan-dev-help@xml.apache.org


Mime
View raw message