xml-xalan-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joakim Bomelin <joa...@bomelin.com>
Subject ApacheModuleXSLT (Urgent)
Date Sun, 30 Jun 2002 12:44:57 GMT

Hi.
I tried to compile ApacheModuleXSLT using the Makefile in Xalan, but that 
didn't work out. So I used apxs -i -a -c mod_xslt.c -lxalan-c1_3, which worked 
out OK.

According to http://xml.apache.org/xalan-c/samples.html#apachemodulexslt I put 
AddModule mod_xslt.c and LoadModule xslt_module mod_xslt.so in my httpd.conf, 
and I get "Cannot add module via name 'mod_xslt.c': not in list of loaded 
modules". If I use only LoadModule xslt_module mod_xslt.so Apache starts up OK, 
so I carry on with adding
<Location /xslt/>
  AddHandler xslt_module .html
</Location>
to my VirtualHost in httpd.conf. When I point my browser to 
http://mecka1.pennans.net/xslt/foo.html I get a 404 (see log-entry below), 
allthough both foo.xml and foo.xsl resides in xslt/ in the document root.

[Sun Jun 30 14:45:48 2002] [notice] Apache/1.3.19 (Unix) mod_xslt/Xalan/1.0 
PHP/4.0.4pl1 mod_perl/1.25 configured -- resuming normal operations
[Sun Jun 30 14:45:48 2002] [notice] suEXEC mechanism enabled 
(wrapper: /usr/local/apache/bin/suexec)
[Sun Jun 30 14:47:15 2002] [error] [client 10.0.0.15] File does not 
exist: /home/www/mecka1.pennans.net/xslt/foo.html

What can I do to fix this?
I use Apache 1.3.19, Slackware 7.1 and Linux 2.2.16 (old stuff, I know :))

/Joakim

Mime
View raw message