xml-soap-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre Yves Monnet" <pierre-yves.mon...@cgey.com>
Subject It's working fine !
Date Thu, 07 Nov 2002 08:28:59 GMT
Hello everybody, and thanks to Scott and Thibault for their help.

My integration in a servlet are working fine. The only last (strange) problem I had was to
deployed a service.

Using the HTML & JSP admininstration didn't work well. Service was registered in the HTML
& JSP screen, but the servlet said 'fresh start'.
One of my collegue register the service using the XML declaration, and it works fine now !

The strange behavior is that the service declared via XML ... is visible in the HTML &
JSP administration !

So, to integrated Soap in a servlet, do the following :

in the method init( ServletConfig config)
{
    ....
   mSoapRouter = new RPCRouterServlet ();
    mSoapRouter.init( config );
}

in the method service( HttpServletRequest request, HttpServletResponse response ) :
{
    ...
    if (request.getParameter( "webservice" )!=null) // only question is here in your servlet
: on which parameter to switch to Soap ?
    {
      mSoapRouter.service( request, response );
      return;
    }
    // do your own job
}
Then, declare your service using the XML declaration, nor the HTML & JSP administration.



Pierre-Yves Monnet


--------------------------------------------------------------------------------

Pierre-Yves Monnet - Project Manager

Cap Gemini Ernst & Young



Tél  :   33 (0) 4 76 52 64 23
GSM:  33 (0) 6 86 74 49 86

FAX : 33 (0)4 76 52 62 01 

mail : Pierre-Yves.Monnet@capgemini.fr


Mime
View raw message