xml-soap-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Miller Crawford" <...@websight.co.nz>
Subject Re: Further along, new problem... solved!
Date Sun, 02 Jun 2002 04:28:41 GMT
Well, never assume anything! I had assumed TcpTunnelGui would give me the
same result as Jason got. When I tried it, Tomcat threw up an error 500,
just the same as Jason -- but for a different cause. It was produced by a
NoClasssDefFound and the reason for that was that somehow, I'd managed to
drop activation.jar out of Tomcat's classpath. With that back in there, I
was back in business.

So there really was "some stupidly simple answer" as I suspected.

So, thanks guys (Erich and Jason in particular), for showing me the path I
needed to go down!

John

----- Original Message -----
From: John Miller Crawford
To: soap-user@xml.apache.org
Sent: Saturday, 1 June 2002 11:01
Subject: Re: Further along, new problem...


As a SOAP newbie, I have an identical problem to Jason's, but I'm afraid his
solution doesn't work for me:

>> when I installed Apache SOAP, I followed method 2, which has you create
>> a context based on the non-WAR /soap directory. This doesn't work. You
>> must use the WAR file

I did use deployment method 1, putting the WAR file in
%tomcat_home%/webapps.

However, I still get the identical NullPointerException that vexed Jason:

java.lang.NullPointerException
         at
org.apache.soap.transport.TransportMessage.read(TransportMessage.java:206)
         at org.apache.soap.util.net.HTTPUtils.post(HTTPUtils.java:333)
         at org.apache.soap.transport.http.SOAPHTTPConnection.send
(SOAPHTTPConnection.java:282)
         at org.apache.soap.rpc.Call.invoke(Call.java:205)
         at GetMessage.main(GetMessage.java:43)

(Apache SOAP Admin shows that the service that GetMessage is calling is
deployed.)

I haven't used TcpTunnelGui yet -- I'm assuming I'd get the same result as
Jason got and there's some stupidly simple answer -- is there?

TIA

John


Mime
View raw message