xml-soap-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kim Altintop <...@ds.fh-koeln.de>
Subject Re: Soap https problems
Date Thu, 14 Feb 2002 12:25:10 GMT
Hi Antonino,

I encountered the same problem and wasn't able to solve it until now. I
posted on this list but got no answer :(
What I came up with:

-> 1: This might be a Problem with the location/setup of your keystore(s).
It worked for me after going through the tutorials several times...

-> 2: If you start your java client with "-Djavax.net.debug=ssl" you can
trace the whole SSL protocol sequence. I tested it with both a
SOAP-over-SSL and the "SSLSocketWithClientClientAuth"-sample that comes
with JSSE. The latter one worked fine whereas the SOAP client exited with
the same message as yours. From the SSL debug trace I could see that the
client was unable to send its certificate upon request of the server - no
idea why.
Finally I came up with using HTTP BASIC AUTH over HTTPS - shouldn't have
any serious security implications as the creds are encrypted as they travel
over network. Let me now if you need help with this.

Regards,
Kim


--On 2/14/2002 8:08 AM +0000 Antonino Galletta
<antonino.galletta@objectway.it> wrote:

> Dear all,
> 
> I'm tryng ot use apache soap 2.2and Tomcat 3.2  to build https
> clients/server following the instruction on
> <http://xml.apache.org/soap/docs/install/FAQ_Tomcat_SOAP_SSL.html>
> 
> but i fonded two problem:
> 
> 	1 including the tag  <Parameter name="clientAuth" value="true"/> into the
> tomcat config file server.xml
> 	  the iexplorer is not able to to connect the Tomcat also if the server
> certificate has ben imported.
> 
> 	2 connecting to the server with a Java soap client it trows this
> exception 	  	Using https to connect to owtp10 on port #8443
> 		Caught SOAPException (SOAP-ENV:Client): Error opening socket: null
> 		[SOAPException: faultCode=SOAP-ENV:Client; msg=Error opening socket:
> null; targetException=java.lang.IllegalArgumentException: Error opening
> socket: null]
>         	at
> org.apache.soap.transport.http.SOAPHTTPConnection.send(SOAPHTTPConnection
> .ja va:324)
>         	at org.apache.soap.rpc.Call.invoke(Call.java:205)
> 
> 	  but the port #8443 is open on the server.
> 
> 
> Thank for your help
> Antonino Galletta



Mime
View raw message