xml-soap-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kumar Raj <kumar...@india.hp.com>
Subject Re: list, deploy and un-deploy not working
Date Thu, 07 Jun 2001 04:07:34 GMT
All the jar files under tomcat/lib will be set automatically when
you run the <tomcat_home>/bin/tomcat.bat.
Just ensure in the tomcat window that you dont see anyother servlet.jar file
like jsdk.jar or so.

Hugo Bouckaert wrote:

> Thanks for that.
>
> You are right, I have several other jar files in the <tomcat-home>/lib
> directory. But I think I need those. I have: ant.jar, jasper.jar,
> jaxp.jar, parser.jar and webserver.jar. What would be the best place to
> put those?
>
> Thanks
>
> Hugo
>
> Kumar Raj wrote:
> >
> > Hi
> > As you previously did, xerces.jar should be in the first of the classpath.
> > The reason you are getting java.lang.NoClassDefFoundError:
> > javax/servlet/http/HttpServlet
> > error may be becos there are some other servlet.jar in the classpath,other
> > than the servlet.jar file
> > which comes with the <tomcat_home>/lib. Just try putting only the
> > <tomcat_home>/lib/servlet.jar
> > in the classpath.
> >
> > Regards
> > Kumar Raj
> >
> > Hugo Bouckaert wrote:
> >
> > > Hi
> > >
> > > I am trying to establish a SOAP connection between a soap server working
> > > with tomcat (soap2.1 and tomcat3.2.1) and I have set up a test service.
> > >
> > > I eventually found out that a problem with "method not found" referred
> > > to the fact that I didn't have my xerces.jar as the very first thing in
> > > my path. But then I got a "connection refused" error when I tried to
> > > make a connection as a client. So I thought to have another look at my
> > > server setup for the service I was trying to make use of. Now i can't
> > > run the service any longer as when I click on "deploy", or "list" I get
> > > the following error:
> > >
> > > Root cause:
> > >
> > > java.lang.NoClassDefFoundError: javax/servlet/http/HttpServlet
> > >
> > > I even took out xerces.jar as my first path entry in CLASSPATH and
> > > started tomcat in a new shell - but this does not make any difference
> > > anymore "list", "deploy" and "un-deploy" still do not work. Can anyone
> > > help me with this as I am getting increasingly confused - I have no idea
> > > anymore as to what is going on. Why can soap no longer find a class when
> > > all I did was change the CLASSPATH but then changed it back to its
> > > original configuration?
> > >
> > > Thanks
> > >
> > > Hugo
> > >
> > > --
> > > Dr Hugo Bouckaert
> > > R&D Support Engineer, Fractal Graphics
> > > 39 Fairway, Nedlands Western Australia 6009
> > > Tel: +618 9386 7917
> > > Email:hugo@fractalgraphics.com.au
> > > Web: http://www.fractalgraphics.com.au
>
> --
> Dr Hugo Bouckaert
> R&D Support Engineer, Fractal Graphics
> 39 Fairway, Nedlands Western Australia 6009
> Tel: +618 9386 7917
> Email:hugo@fractalgraphics.com.au
> Web: http://www.fractalgraphics.com.au


Mime
View raw message