xml-soap-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brown, Keith" <KBr...@develop.com>
Subject FW: SOAP/Perl progress report
Date Fri, 11 Aug 2000 00:05:14 GMT
As a newbie to this list, is there an archive of old messages somewhere?
 
-----Original Message-----
From: Brown, Keith [mailto:KBrown@DEVELOP.COM]
Sent: Thursday, August 10, 2000 3:44 PM
To: SOAP@DISCUSS.DEVELOP.COM
Subject: [SOAP] SOAP/Perl progress report


I'm testing SOAP/Perl against the apache xml-soap implementation, and I now
see what you mean about type-encoding each element. They reject any requests
that don't have xsi:type attributes on all of the parameters.
 
I hacked my code to send all parameters as xsd:string, and now I get a fault
code of
<faultstring>org/apache/soap/util/MethodUtils$MoreSpecific</faultstring>
 
which seems to indicate that I need to specify the actual types as opposed
to strings (or just use strings in all my test snippets ;-)
 
This isn't looking good from a Perl programmer's perspective - we don't have
that sort of type information in Perl.
 
Can anybody on the apache team help me here?
 
Keith

-----Original Message-----
From: Steven McDowall [mailto:sjm@APTEST.COM]
Sent: Tuesday, August 08, 2000 8:06 AM
To: SOAP@DISCUSS.DEVELOP.COM
Subject: Re: [SOAP] SOAP spec 1.1 and SOAP/Perl 0.23?


Hmm..How "compliant" is the question .. To which version?
 
Are you (which I did) going to type encode each element as 
xsi:type="xsd:string" so it works with an apache SOAP server?
 
with the proper constants, etc?
 
Just wondering
 
-Steve




Mime
View raw message