xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "P.Ruijters" <p.ruijt...@chello.nl>
Subject Starter..Error: 500 Location: /xalanservlet/servlet/SimpleXSLTServlet
Date Wed, 11 Jun 2003 21:58:30 GMT
Hello,

Hope I can put this question here. I recently installed xalan-j_2_5_1. I did set classpathes
and got the non servlet examples going allright. But somehow I can't get the servlet examples
going. 
I do have 
C:\jakarta-tomcat-3.2.4\webapps\xalanservlet  (directory)
C:\jakarta-tomcat-3.2.4\webapps\xalanservlet.war

trying http://localhost/xalanservlet/servlet/SimpleXSLTServlet gives "
Error: 500 Location: /xalanservlet/servlet/SimpleXSLTServlet"

Can sombody tell me maybe what has gone wrong here.

Thanks
Pierre
====================================
additional info error message:
Error: 500
Location: /xalanservlet/servlet/SimpleXSLTServlet
Internal Servlet Error:

javax.xml.transform.TransformerFactoryConfigurationError: java.lang.ClassNotFoundException:
org.apache.xalan.processor.TransformerFactoryImpl
	at javax.xml.transform.TransformerFactory.newInstance(TransformerFactory.java:121)
	at servlet.SimpleXSLTServlet.doGet(SimpleXSLTServlet.java:102)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:405)
	at org.apache.tomcat.core.Handler.service(Handler.java:287)
	at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:806)
	at org.apache.tomcat.core.ContextManager.service(ContextManager.java:752)
	at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:213)
	at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:501)
	at java.lang.Thread.run(Thread.java:479)
additional info classpath settings:

My classpath is set as follows:

CLASSPATH=.;C:\jakarta-tomcat-3.2.4\webapps\xalanservlet.war;"C:\xalan-j_2_5_1\bin\xalan.jar;C:\xalan-j_2_5_1\bin\xml-apis.jar";"C:\xalan-j_2_5_1\bin\xercesImpl.jar";"C:\xalan-j_2_5_1\bin\jarxalansamples.jar";"C:\xalan-j_2_5_1\bin\xalanservlet.jar";C:\jakarta-tomcat-3.2.4\lib\servlet.jar;C:\jakarta-tomcat-3.2.4\lib\webserver.jar;C:\jakarta-tomcat-3.2.4\lib\webserver.jar\;C:\jakarta-tomcat-3.2.4\lib\jaxp;C:\jakarta-tomcat-3.2.4\lib\crimson.jar;C:\jakarta-tomcat-3.2.4\lib;C:\jakarta-tomcat-3.2.4\lib\ant.jar;
(I put in just about any jar here not really knowing if this should be there but just in case)
Mime
View raw message