xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elliotte Rusty Harold <elh...@metalab.unc.edu>
Subject Re: TCK compliance [was: is there such a thing as a common xml-apis.jar]
Date Thu, 07 Nov 2002 16:10:05 GMT
At 10:54 AM -0500 11/7/02, Elena Litani wrote:
>JAXP 1.2 conformance section states that all implementations of JAXP
>need to be conformant to the following specifications: XML 1.0 Rec., SAX
>2.0, XSLT 1.0, and DOM Level 2 Core.
>
>So what happens when new versions of the specifications come out, i.e.
>XML 1.1 (CR), SAX 2.0.1, XSLT 2.0 and DOM Level 3 Core?

Of those, I think XML 1.1 is the only one that matters. I think the 
other three are all strict supersets of the earlier specs. (Well, 
XSLT isn't; but the version attribute lets you figure out which 
version you've got a hold of.) I don't think you can be compliant 
with SAX 2.0.1 or DOM3 without being compatible with SAX 2.0 and DOM 
2. XML 1.1 is an issue.
-- 

+-----------------------+------------------------+-------------------+
| Elliotte Rusty Harold | elharo@metalab.unc.edu | Writer/Programmer |
+-----------------------+------------------------+-------------------+
|          XML in a  Nutshell, 2nd Edition (O'Reilly, 2002)          |
|              http://www.cafeconleche.org/books/xian2/              |
|  http://www.amazon.com/exec/obidos/ISBN%3D0596002920/cafeaulaitA/  |
+----------------------------------+---------------------------------+
|  Read Cafe au Lait for Java News:  http://www.cafeaulait.org/      |
|  Read Cafe con Leche for XML News: http://www.cafeconleche.org/    |
+----------------------------------+---------------------------------+

---------------------------------------------------------------------
In case of troubles, e-mail:     webmaster@xml.apache.org
To unsubscribe, e-mail:          general-unsubscribe@xml.apache.org
For additional commands, e-mail: general-help@xml.apache.org


Mime
View raw message