xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Garrington, Richard" <richard.garring...@wcom.co.uk>
Subject ld: Can't find library for -lexpat
Date Thu, 11 Jul 2002 14:03:16 GMT
Hello

OS=hpux 11.11 64 bit, using HP's ANSI compiler

Installed expat-1.95.3, libexpat* libraries installed /usr/local/lib
Tried to make XML-Parser-2.31, got error;

# ls /usr/local/lib 
libexpat.a       libexpat.la      libexpat.sl      libexpat.sl.2
libexpat.sl.2.0
# 
# 
# perl Makefile.PL EXPATLIBPATH=/usr/local/lib
EXPATINCPATH=/usr/local/include
Checking if your kit is complete...
Looks good
Writing Makefile for XML::Parser::Expat
Writing Makefile for XML::Parser
# make
cp Parser/Encodings/README blib/lib/XML/Parser/Encodings/README
cp Parser/Encodings/x-sjis-cp932.enc
blib/lib/XML/Parser/Encodings/x-sjis-cp932.enc
cp Parser/Encodings/iso-8859-7.enc
blib/lib/XML/Parser/Encodings/iso-8859-7.enc
cp Parser/Encodings/big5.enc blib/lib/XML/Parser/Encodings/big5.enc
cp Parser/Encodings/windows-1250.enc
blib/lib/XML/Parser/Encodings/windows-1250.enc
cp Parser/Encodings/iso-8859-8.enc
blib/lib/XML/Parser/Encodings/iso-8859-8.enc
cp Parser/Encodings/iso-8859-2.enc
blib/lib/XML/Parser/Encodings/iso-8859-2.enc
cp Parser/Encodings/x-euc-jp-jisx0221.enc
blib/lib/XML/Parser/Encodings/x-euc-jp-jisx0221.enc
cp Parser/Encodings/iso-8859-9.enc
blib/lib/XML/Parser/Encodings/iso-8859-9.enc
cp Parser/Encodings/x-sjis-unicode.enc
blib/lib/XML/Parser/Encodings/x-sjis-unicode.enc
cp Parser/Encodings/iso-8859-3.enc
blib/lib/XML/Parser/Encodings/iso-8859-3.enc
cp Parser/Encodings/x-sjis-jdk117.enc
blib/lib/XML/Parser/Encodings/x-sjis-jdk117.enc
cp Parser/Encodings/euc-kr.enc blib/lib/XML/Parser/Encodings/euc-kr.enc
cp Parser/Encodings/iso-8859-4.enc
blib/lib/XML/Parser/Encodings/iso-8859-4.enc
cp Parser/Encodings/Japanese_Encodings.msg
blib/lib/XML/Parser/Encodings/Japanese_Encodings.msg
cp Parser/Encodings/x-sjis-jisx0221.enc
blib/lib/XML/Parser/Encodings/x-sjis-jisx0221.enc
cp Parser.pm blib/lib/XML/Parser.pm
cp Parser/Encodings/iso-8859-5.enc
blib/lib/XML/Parser/Encodings/iso-8859-5.enc
cp Parser/Encodings/x-euc-jp-unicode.enc
blib/lib/XML/Parser/Encodings/x-euc-jp-unicode.enc
cp Parser/LWPExternEnt.pl blib/lib/XML/Parser/LWPExternEnt.pl
cp Expat.pm ../blib/lib/XML/Parser/Expat.pm
        /usr/bin/perl -I/opt/perl5/lib/5.6.1/PA-RISC2.0
-I/opt/perl5/lib/5.6.1 /opt/perl5/lib/5.6.1/ExtUtils/xsubpp -noprototypes
-typemap /opt/perl5/lib/5.6.1/ExtUtils/typemap -typemap typemap Expat.xs >
Expat.xsc && mv Expat.xsc Expat.c
        /opt/ansic/bin/cc -c -I/usr/local/include -D_HPUX_SOURCE +DD64 -Ae
-I/usr/local/include +z -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O
-DVERSION=\"2.31\"  -DXS_VERSION=\"2.31\" +z
-I/opt/perl5/lib/5.6.1/PA-RISC2.0/CORE  Expat.c
Running Mkbootstrap for XML::Parser::Expat ()
        chmod 644 Expat.bs
        rm -f ../blib/arch/auto/XML/Parser/Expat/Expat.sl
        LD_RUN_PATH="/usr/local/lib" /usr/bin/ld  -b +vnocompatwarnings
-L/usr/local/lib -L/lib/pa20_64 Expat.o  -o
../blib/arch/auto/XML/Parser/Expat/Expat.sl   -L/usr/local/lib -lexpat  
ld: Can't find library for -lexpat
Fatal error.
*** Error exit code 1

Summary of my perl5 (revision 5.0 version 6 subversion 1) configuration:
  Platform:
    osname=hpux, osvers=11.11, archname=PA-RISC2.0-thread
    uname='hp-ux bianca b.11.11 u 9000800 1493622342 unlimited-user license
'
    config_args='-Duse64bitall'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=define use5005threads=define useithreads=undef
usemultiplicity=undef
    useperlio=undef d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
  Compiler:
    cc='/opt/ansic/bin/cc', ccflags =' -D_HPUX_SOURCE +DD64 -Ae
-D_LARGEFILES_SOURCE -D_FILE_OFFSET_BITS=64 +z -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 ',
    optimize='-O',
    cppflags='-D_HPUX_SOURCE +DD64 -Ae -D_LARGEFILES_SOURCE
-D_FILE_OFFSET_BITS=64 +z'
    ccversion='B.11.11.04', gccversion='', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=87654321
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t',
lseeksize=8
    alignbytes=8, usemymalloc=n, prototype=define
  Linker and Libraries:
    ld='/usr/bin/ld', ldflags =' +DD64 -Wl,+vnocompatwarnings
-L/usr/local/lib -L/lib/pa20_64'
    libpth=/usr/local/lib /lib/pa20_64 /lib /usr/lib /usr/ccs/lib
    libs=-lcl -lpthread -lnsl -lnm -ldld -lm -lc -lsec
    perllibs=-lcl -lpthread -lnsl -lnm -ldld -lm -lc -lsec
    libc=/lib/pa20_64/libc.sl, so=sl, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_hpux.xs, dlext=sl, d_dlsymun=undef, ccdlflags='-Wl,-E
-Wl,-B,deferred '
    cccdlflags='+z', lddlflags='-b +vnocompatwarnings -L/usr/local/lib
-L/lib/pa20_64'


Characteristics of this binary (from libperl): 
  Compile-time options: USE_THREADS USE_64_BIT_INT USE_64_BIT_ALL
USE_LARGE_FILES PERL_IMPLICIT_CONTEXT
  Built under hpux
  Compiled at Jul  3 2002 18:57:31
  @INC:
    /opt/perl5/lib/5.6.1/PA-RISC2.0-thread
    /opt/perl5/lib/5.6.1
    /opt/perl5/lib/site_perl/5.6.1/PA-RISC2.0-thread
    /opt/perl5/lib/site_perl/5.6.1
    /opt/perl5/lib/site_perl



Any help welcome

Rdgs
Richard



Mime
View raw message