xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary L Peskin <ga...@firstech.com>
Subject Re: xsl:import in Xalan2j
Date Wed, 08 Aug 2001 14:35:46 GMT
Harald --

This should be working properly in Xalan2J.  How are you kicking off the
build of the Templates object?  You might try doing a setSystemId(..)
call on your stylsheet Source to let XalanJ2 know where it is.

Gary

Harald Hett wrote:
> 
> Hi,
> while switching from Xalan1.2j to Xalan2j,
> I encountered a strange behaviour with xsl:import.
> 
> setting:
>   In a directory style lie the two files main.xsl and parameters.xsl.
>   The file main.xsl imports the script parameters.xsl with
>     <xsl:import href="parameters.xsl"/>
>   In a different directory (work) lie all the xml files to process and
>   a script, that starts the processing.
> 
> problem:
>   Up to now the processor has found the imported file in style.
>   But with Xalan 2 (using TRaX), the processor tries to find
>   it in the directory work.
> 
> Is this a feature or a bug? And how can I set the old behavior?
> 
> Thanks in advance!
> --
> Harald Hett <h.hett@gis-systemhaus.de>
> Gesellschaft für integrierte Systemplanung
> 
> ---------------------------------------------------------------------
> In case of troubles, e-mail:     webmaster@xml.apache.org
> To unsubscribe, e-mail:          general-unsubscribe@xml.apache.org
> For additional commands, e-mail: general-help@xml.apache.org

---------------------------------------------------------------------
In case of troubles, e-mail:     webmaster@xml.apache.org
To unsubscribe, e-mail:          general-unsubscribe@xml.apache.org
For additional commands, e-mail: general-help@xml.apache.org


Mime
View raw message