xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott_B...@lotus.com
Subject Re: FW: inconsistent results with xalan-j 2
Date Tue, 03 Jul 2001 16:11:43 GMT

Heather, we did get the message on the xalan-dev list, but I guess you
didn't get the reply...

----- Forwarded by Scott Boag/CAM/Lotus on 07/03/01 05:40 AM -----
                                                                                         
                         
                    Scott Boag                                                           
                         
                                         To:     xalan-dev@xml.apache.org                
                         
                    07/02/01 09:48       cc:     "Sanjay Bhakta \(E-mail\)" <sbhakta@prodigy.net>
                 
                    AM                   Subject:     Re: inconsistent results with xalan-j
2(Document link: Scott 
                                         Boag)                                           
                         
                                                                                         
                         



It's hard to debug it from here.  Are you reusing Transform objects?  Is
threading involved?

If I were to guess, I would suspect the inconsistent results are caused by
the racing threads in the Stree/Transform.

Since you are on a short timeframe, it might be worth building the latest
code from the CVS, or trying the latest developer's release of 2.2.0.
Since the latest stuff doesn't have racing threads, it would be interesting
to see if the problem goes away.

-scott




                                                                                         
                         
                    "Heather                                                             
                         
                    Lloyd"               To:     <general@xml.apache.org>          
                               
                    <hlloyd@prodi        cc:     (bcc: Scott Boag/CAM/Lotus)          
                            
                    gy.net>              Subject:     FW: inconsistent results with xalan-j
2                      
                                                                                         
                         
                    07/03/01                                                             
                         
                    08:07 AM                                                             
                         
                    Please                                                               
                         
                    respond to                                                           
                         
                    general                                                              
                         
                                                                                         
                         
                                                                                         
                         




i suspect this posting belongs on xalan-dev, where i had originally sent it
before foolishly realizing that i'm not on its subscription list :(
while i'm attempting to subscribe there, if anyone has any help to offer on
the following question i'd be grateful.  thanks...hl

 -----Original Message-----
From:           Heather Lloyd [mailto:hlloyd@prodigy.net]
Sent:           Sunday, July 01, 2001 11:53 AM
To:        'xalan-dev@xml.apache.org'
Cc:        Sanjay Bhakta (E-mail)
Subject:        inconsistent results with xalan-j 2

i'm using xalan-j 2.1.0 with the redirect extension to parse an xml file
and
produce 5 redirected output files.  each time i run the parser with the
same
xml and xsl files i get different results. (yeah, i know you're skeptical.
but i have witnesses :(   )  sometimes the file is successfully parsed.
sometimes i the parser thows an exception reporting the following useless
message:

XSLT Error (javax.xml.transform.TransformerException): TRaX Transform
Throwable

very occasionally a line number is reported, and it seems always to be on
one of the 5 xsl statements that looks as follows:

<redirect:write file="some_name.html">

this write statement is part of a section which repeats in my stylesheet
and
looks as follows:

<xsl:template match="article[@storyorder=1]">
        <xsl:if test="@source='some value'">
        <redirect:write file="some_name.html">
        <![CDATA[<a href="javascript:var open_child_window=window.open
('someurl_]]><xsl:value-of select="//sitepartner"
/><![CDATA[.asp?id=]]><xsl:value-of select="filename"/><![CDATA[','mp'
,'height=460,width=520');"><img src="someurl/]]
><xsl:value-of select="filename"/><![CDATA[.jpg" width="92" height="69
" border="0" alt="somealtname"><br><FONT size="2" face="Arial, tahoma"
 color="#2e6890">]]><xsl:value-of select="headline"/><![CDATA[</a>]]>
        </redirect:write>
        </xsl:if>

        <xsl:if test="@source='some other value'">
        <redirect:write file="some_other_name.html">
        <![CDATA[<a href="javascript:var open_child_window=window.open
('someotherurl_]]><xsl:value-of select="//sitepartner"
/><![CDATA[.asp?id=]]><xsl:value-of select="filename"/><![CDATA[','mp'
,'height=460,width=520');"><img src="someotherurl/]]
><xsl:value-of select="filename"/><![CDATA[.jpg" width="92" height="69
" border="0" alt="someotheraltname"><br><FONT size="2" face="Arial, tahoma"
 color="#2e6890">]]><xsl:value-of select="headline"/><![CDATA[</a>]]>
        </redirect:write>
        </xsl:if>
                     ...
  </xsl:template>

does anyone see what's wrong here?  this application is harvesting data
from
an external source and producing html for a production system.  i can't use
this product in a production system if it behaves unreliably, and i've got
a
launch coming up in a week.
i would be grateful for any feedback.  thanks in advance...hl


"...sapias.  vina liques.  et spatio brevi spem longam reseces.  dum
loquimur fugerit invida aetas."

(See attached file: Heather Lloyd (E-mail).vcf)
---------------------------------------------------------------------
In case of troubles, e-mail:     webmaster@xml.apache.org
To unsubscribe, e-mail:          general-unsubscribe@xml.apache.org
For additional commands, e-mail: general-help@xml.apache.org


Mime
View raw message