xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald_Les...@lotus.com
Subject Re: Anybody know how to use xml-stylebook with xml-xalan2?
Date Wed, 07 Mar 2001 20:41:58 GMT

**I HAVE RECEIVED A WARNING ABOUT THE FILE ATTACHMENT YOU INCLUDED, SO I AM
PURGING IT FROM MY REPLY**
I did the following:

1. A cvs update of xml--stylebook to make sure I have the latest from the
repository

2. Used ant 1.3 and xml-stylebook\build.xml (package2 target) to rebuild
stylebook-1.0-b3-xalan-2.jar.

3. Put the new stylebook jar in xml-xalan\java\bin and rebuilt the Xalan
doc.
Note: set the classpath to use ant 1.3, xerces 1.3, (in xml-xalan-java\bin)
and the latest xalan (in xml-xalan-java\build).

4. Put the new stylebook jar in a copy of the  Xalan-J2 distribution tree
(xalan-j_2_0_0\bin) and rebuilt the Xalan doc.
Note: set the classpath to use ant 1.3, xerces 1.2.3, and xalan 2.0 (in
xalan-j_2_0_0\bin)

In both environments, I had no problems building the Xalan doc, so it looks
to me like the problem is something else on the classpath getting in the
way??? Just to make sure, perhaps you could try rebuilding stylebook and
veryifying that it works when placed in the xml-xalan\java\bin directory.
If there is a problem with the stylebook build, you might try manually
changning XalanProcessor.java to Xalan2Processor.java in engine.xml (that
is how I used to do it before someone submitted a build patch that makes
that change within the xml-stylebook build.
-- Don




"Sam Ruby" <rubys@us.ibm.com> on 03/07/2001 01:19:14 PM

To:   general@xml.apache.org
cc:   Donald_Leslie@lotus.com, Shane_Curcuru@lotus.com

Subject:  Re: Anybody know how to use xml-stylebook with xml-xalan2?

Donald Leslie wrote:
>
> I'm not sure what is going on. I assume you are building
> stylenbook for Xalan-J 2, which in addition to putting
> Xalan-J2 and a recent Xerces on the classpath, means
> including Xalan2Processor.java, excluding
> XalanProcessor.java, and changing "XalanProcessor:" to
> "Xalan2Processor" in xslt processor setting in engine.xml.
>
> The messages below seem to indicate a problem building
> the Xalan-J2 design document, which (because of the size
> of the graphics) uses 2 custom stylesheets:
> design2project.xsl and designdoctohtml.xsl (so far as I
> am aware not used by another project). When i run the
> standard Ant build to build Xalan-J2 doc, including this
> design document, I have no problems.
>
> Please try rebuilding stylebook, taking note of the build
> requirements mentioned above. Hopefully this will straighten
> things out.

I'm attaching a batch file which it set up to use VERY recent Ant, Xalan,
Xerces, an Stylebook codebases and demonstrates the problem.  ;-) You will
see what I mean when you look inside.  Let me know if you would prefer a
shell script equivalent.

(See attached file: stylebook2.bat)

- Sam Ruby

P.S.  Feel free to substitute not-so-fresh copies of Ant and Xerces.





Mime
View raw message