xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Ye" <eri...@locus.apache.org>
Subject Re: Not receiving DOM_ATTR_MODIFIED notifications
Date Wed, 06 Dec 2000 00:34:35 GMT
Just want to help you post this on the xerces-j mailing list,

BTW, I used my own progarm to test this, could not reproduce the problem.
would you mind posting the code snippet that fail to receive the Mutation
events?
_____


Eric Ye * IBM, JTC - Silicon Valley * ericye@locus.apache.org

----- Original Message -----
From: "Jeff Boston" <daddyb@us.ibm.com>
To: <general@xml.apache.org>
Sent: Tuesday, December 05, 2000 10:59 AM
Subject: Not receiving DOM_ATTR_MODIFIED notifications


> Trying this list since I don't see my notes on the
> xerces-j-dev@xml.apache.org list.
>
> Jeff Boston
> ---------------------- Forwarded by Jeff Boston/Watson/IBM on 12/05/2000
> 01:52 PM ---------------------------
>
> Jeff Boston
> 12/01/2000 03:14 PM
>
> To:   xerces-j-dev@xml.apache.org
> cc:
> From: Jeff Boston/Watson/IBM@IBMUS
> Subject:  Not receiving DOM_ATTR_MODIFIED notifications
>
>
> I sent this previously to the xerces-j-dev@xml.apache.org list but still
> haven't seen it so I'll resend it.
>
> I checked with the latest, Xerces 1.2.2,  and the bug is still there.
>
> Jeff Boston
>
> ---------------------- Forwarded by Jeff Boston/Watson/IBM on 12/01/2000
> 03:01 PM ---------------------------
>
>
> It appears that I don't receive DOM_ATTR_MODIFIED notifications when I add
> an element to the tree and modify attributes which have a default value in
> the .dtd file.  If I load the DOM tree from a file and then modify the an
> element's attributes that exist in the tree I receive the change
> notification.  If I add an elements to the tree and then modify attributes
> which don't specify a default value in the .dtd (#IMPLIED) then I also
> receive the change notification.  But if I change the #IMPLIED to a
default
> value in the .dtd, and then modify the added elements attributes with
> default values I don't receive the change notification.  Setting the
> feature to http://apache.org/xml/features/nonvalidating/load-dtd-grammar
to
> false did not change the notification problem.  I didn't test with a
> schema.
>
> Using xerces 1.2.1 and jdk 1.2.2
>
> Jeff Boston
>
>
>
>
> ---------------------------------------------------------------------
> In case of troubles, e-mail:     webmaster@xml.apache.org
> To unsubscribe, e-mail:          general-unsubscribe@xml.apache.org
> For additional commands, e-mail: general-help@xml.apache.org
>
>


Mime
View raw message