xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Beard <ebeard_40...@yahoo.com>
Subject Trying to get previously valid XML/XSL/DTD to work
Date Tue, 14 Nov 2000 05:17:07 GMT
I was having problems getting a construct in my DTD to
work without crashing the lotusxsl parser and so I
thought it would be wise to get a newer XML parser.

I have tried to figure this out from the FAQs,
examples and archives, but I'm missing something.

I have installed the 1.2.1 version of Xerces for java
(running SUN JDK 1.3 on Win98).  When I use the my
command:
C:\SPEC>java.exe org.apache.xalan.xslt.Process  -IN
defs\AlertBytes.xml -XSL all.xsl -OUT info.html
-VALIDATE > out

to process my files, I get the following output:

Parser error: General Schema Error: Grammar with uri
2: http://www.w3.org/1999/XSL/Transform , can not
found.
Parser error: Element type "xsl:stylesheet" must be
declared.

The first two lines of my XSL file are

<?xml version="1.0"?> 
<xsl:stylesheet
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
version="1.0">

What do I need to do to make things happy again?

Thanks,
Eric




__________________________________________________
Do You Yahoo!?
Yahoo! Calendar - Get organized for the holidays!
http://calendar.yahoo.com/

Mime
View raw message