xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald_Les...@lotus.com
Subject Re: Problem with Xalansamples
Date Fri, 13 Oct 2000 19:39:01 GMT

I assume you are talking about Xalan-Java 1 (although Xalan-Java 2 has a
sample with the same name). The class name for this sample
is SimpleTransform and the xml source and xsl stylesheet are in
samples/SimpleTransform. Put the xalansamples.jar on your classpath. From
the samples/SimpleTransform directory, try
      java SimpleTransform

-- Don




fredric larsson <fredric.larsson@exertus.se> on 10/13/2000 08:32:16 AM

Please respond to general@xml.apache.org

To:   general@xml.apache.org
cc:    (bcc: Donald Leslie/CAM/Lotus)

Subject:  Problem with Xalansamples


Hi,
I have got problem when I'm trying to run the samples for Xalan-J.
If I try to run the "SimpleTransformation" sample it looks like this:

"D:\apache\xerces-1_2_0\samples\SimpleTransform>java SimpleTransformation
Exception in thread "main" java.lang.NoClassDefFoundError:
SimpleTransformation

D:\apache\xerces-1_2_0\samples\SimpleTransform>"



And if I try to compile the ".java" file it looks like this:

"D:\apache\xerces-1_2_0\samples\SimpleTransform>java SimpleTransformation
Exception in thread "main" java.lang.NoClassDefFoundError:
SimpleTransformation

D:\apache\xerces-1_2_0\samples\SimpleTransform>javac SimpleTransform.java
SimpleTransform.java:58: Class org.apache.xalan.xslt.XSLTProcessorFactory
not found in import.
import org.apache.xalan.xslt.XSLTProcessorFactory;
       ^
SimpleTransform.java:59: Class org.apache.xalan.xslt.XSLTInputSource not
found in import.
import org.apache.xalan.xslt.XSLTInputSource;
       ^
SimpleTransform.java:60: Class org.apache.xalan.xslt.XSLTResultTarget not
found in import.
import org.apache.xalan.xslt.XSLTResultTarget;
       ^
SimpleTransform.java:61: Class org.apache.xalan.xslt.XSLTProcessor not
found
in import.
import org.apache.xalan.xslt.XSLTProcessor;
       ^
4 errors

D:\apache\xerces-1_2_0\samples\SimpleTransform>"

I have included the ".jar" files in the classpath and "d:\jdk1.2.2\bin" in
the Path.

Dose anybody know what the problem can bee?

I'm using an NT-Server can that bee the problem?

Regards
Fredric

---------------------------------------------------------------------
In case of troubles, e-mail:     webmaster@xml.apache.org
To unsubscribe, e-mail:          general-unsubscribe@xml.apache.org
For additional commands, e-mail: general-help@xml.apache.org









Mime
View raw message