xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias Wahlström <tobias.wahlst...@pricerunner.se>
Subject Strange method names...
Date Tue, 04 Jul 2000 13:43:25 GMT
Hello!

I downloaded the latest xalan version (1.1D01, using Xerces 1.0.3). When I
was trying to use the class org.xml.sax.Attributes (provided in the
xerces.jar file with xalan) the method getRawName() didn't existed, but
another (undocumented?) method named getQName(). When I am trying to use the
class org.w3c.dom.DOMImplementation (also provided in xerces.jar) the
createDocument(3 parameters) doesn't exists either.

I tried to download a binary distribution xerces 1.0.3 from xml.apache.org
and tried to use that xerces.jar in stead. The getRawName() method appeared
but the createDocument(...) problem was still there.

The whole thing seems to be very strange. I belive many others should have
noticed this before me so it is possible this has something to do with my
java compliler or jdk. I am using jikes 1.06 and jdk 1.2.2 RC4 from
blackdown on Linux, I have also tried to use the javac version provided with
jdk 1.2.2.

Does anyone have any idea?

Regards,
Tobias


Mime
View raw message