xml-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul_D...@lotus.com
Subject Re: xsl:include and xsl:import still not working using Jan 08 2000 1 PM cvs
Date Mon, 10 Jan 2000 18:32:43 GMT

Stefano,

I ran your files from the sample/dom1/transform.java  found in the
distribution,  with the latest jar files, created this morning. The results
I got were;
     <?xml version="1.0" encoding="UTF-8"?>
     <html><head><title>Hello</title></head><body bgcolor="#ffffff">
      <h1 align="center">Hello</h1>

       <p align="left"><b>This is my first Cocoon file!</b></p>

     </body></html>

However, I changed the following line from;
  <xsl:import href="../hello/hello-page-html.xsl"/>
to;
     <xsl:import href="cocoonimp.xsl"/>

so essentially the imported file was in the same directory as the original
files.
So I'm not sure what's going on.  We're still investigating.

Paul


                                                                                         
            
                    Stefano                                                              
            
                    Mazzocchi            To:     general@xml.apache.org                  
            
                    <stefano@apac        cc:     (bcc: Paul Dick/CAM/Lotus)           
               
                    he.org>              Subject:     Re: xsl:include and xsl:import still
not        
                                         working using Jan 08 2000 1 PM cvs              
            
                    01/10/2000                                                           
            
                    11:47 AM                                                             
            
                    Please                                                               
            
                    respond to                                                           
            
                    general                                                              
            
                                                                                         
            
                                                                                         
            



Paul_Dick@lotus.com wrote:
>
> Vincent,
>
> This error looks very familiar.  The last time someone was getting this,
> they were trying to output newline characters or whitespace characters to
> the DOM before they had created a root node?  Check to be sure this is
not
> happening in your code.

I get the same stack trace with these files

<?xml version="1.0"?>
<?xml-stylesheet href="import-page-html.xsl" type="text/xsl"?>

<page>
 <title>Hello</title>
 <content>
  <paragraph>This is my first Cocoon file!</paragraph>
 </content>
</page>

<?xml version="1.0"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

  <xsl:import href="../hello/hello-page-html.xsl"/>

  <xsl:template match="paragraph">
   <p align="left">
    <b>
     <xsl:apply-templates/>
    </b>
   </p>
  </xsl:template>

</xsl:stylesheet>


<?xml version="1.0"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

  <xsl:template match="page">
   <html>
    <head>
     <title>
      <xsl:value-of select="title"/>
     </title>
    </head>
    <body bgcolor="#ffffff">
     <xsl:apply-templates/>
    </body>
   </html>
  </xsl:template>

  <xsl:template match="title">
   <h1 align="center">
    <xsl:apply-templates/>
   </h1>
  </xsl:template>

  <xsl:template match="paragraph">
   <p align="center">
    <i>
     <xsl:apply-templates/>
    </i>
   </p>
  </xsl:template>

</xsl:stylesheet>

which work just fine from the command line. It must be something with
the liaison since from the command line this works with no problems...
very strange.

--
Stefano Mazzocchi      One must still have chaos in oneself to be
                          able to give birth to a dancing star.
<stefano@apache.org>                             Friedrich Nietzsche
--------------------------------------------------------------------
 Come to the first official Apache Software Foundation Conference!
------------------------- http://ApacheCon.Com ---------------------





Mime
View raw message